summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLabbe Corentin <clabbe.montjoie@gmail.com>2018-04-09 12:26:58 +0200
committerJonas Stein <jstein@gentoo.org>2018-04-09 19:51:12 +0200
commit78d1f199c40ba158a02b055b79e07d66d708397f (patch)
tree3eddad2089579ba6644d4d631935b7c4e8e26a82 /app-text/odt2txt
parentkde-misc/kdeconnect: Version bump 1.3.0 (diff)
downloadgentoo-78d1f199c40ba158a02b055b79e07d66d708397f.tar.gz
gentoo-78d1f199c40ba158a02b055b79e07d66d708397f.tar.bz2
gentoo-78d1f199c40ba158a02b055b79e07d66d708397f.zip
app-text/odt2txt: bump to 0.5
Closes: https://bugs.gentoo.org/651548 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-text/odt2txt')
-rw-r--r--app-text/odt2txt/Manifest1
-rw-r--r--app-text/odt2txt/files/odt2txt-0.5-darwin_iconv.patch14
-rw-r--r--app-text/odt2txt/odt2txt-0.5.ebuild34
3 files changed, 49 insertions, 0 deletions
diff --git a/app-text/odt2txt/Manifest b/app-text/odt2txt/Manifest
index 4c212d52dc47..f8855f7a0530 100644
--- a/app-text/odt2txt/Manifest
+++ b/app-text/odt2txt/Manifest
@@ -1 +1,2 @@
DIST odt2txt-0.4.tar.gz 23997 BLAKE2B ffa2ac915c1c239cfa7a498fa1597a2462bc7ecd2fb08a90ab50f21a60dbde8abffa52f4b4c40591732f7d497f08774555b36d880214a7708f2c05b692a18908 SHA512 65642dccdb08408e34d484d78be9777aa374cdabbcadd2ab54f43df29db506b136f13e5af720b9b6b6cfdb8508e4fab44159302d35fc002a22979efabf69bfc4
+DIST odt2txt-0.5.tar.gz 24460 BLAKE2B 703dd48447aa38a9a8bc0989231adf6f3dcf2796cb730feef6649cd14bff0265b12d6dba258a2779911f908a8ec322c5543b43222676e78ff12246daa3753b40 SHA512 95d782a088908518191dd0dcd294676fff25c95a2f23a2b8577b8e3adcce2f9d6d5ccaa2a02c7d36be19d05687a4d7a43bed36056c044af0934af810363c7ce0
diff --git a/app-text/odt2txt/files/odt2txt-0.5-darwin_iconv.patch b/app-text/odt2txt/files/odt2txt-0.5-darwin_iconv.patch
new file mode 100644
index 000000000000..05957269888e
--- /dev/null
+++ b/app-text/odt2txt/files/odt2txt-0.5-darwin_iconv.patch
@@ -0,0 +1,14 @@
+diff -ur odt2txt-0.4/Makefile odt2txt-0.4/Makefile
+--- odt2txt-0.4/Makefile 2008-06-23 23:32:28 +0400
++++ odt2txt-0.4/Makefile 2010-05-24 15:39:16 +0400
+@@ -56,6 +56,9 @@
+ CFLAGS += -I$(ZLIB_DIR)
+ LIBS = $(ZLIB_DIR)/libz.a
+ endif
++ifeq ($(UNAME_S),Darwin)
++ LIBS += -liconv
++endif
+ ifeq ($(UNAME_O),Cygwin)
+ CFLAGS += -DICONV_CHAR="const char"
+ LIBS += -liconv
+
diff --git a/app-text/odt2txt/odt2txt-0.5.ebuild b/app-text/odt2txt/odt2txt-0.5.ebuild
new file mode 100644
index 000000000000..71f794e3cdf1
--- /dev/null
+++ b/app-text/odt2txt/odt2txt-0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple converter from OpenDocument Text to plain text"
+HOMEPAGE="http://stosberg.net/odt2txt/"
+SRC_URI="https://github.com/dstosberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~sparc ~x86 ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ !app-office/unoconv
+ sys-libs/zlib
+ virtual/libiconv
+"
+DEPEND="${RDEPEND}
+ sys-apps/groff
+"
+PATCHES="${FILESDIR}/${P}-darwin_iconv.patch"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX=/usr
+ doman odt2txt.1
+}