summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-04-10 16:55:49 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-04-10 16:55:49 +0700
commit1d53662c70af773b63aa84915e74f634cf0ae3df (patch)
treeda52548a75b29548a995aed471a01dc65ce4ca0f /app-text/pdfarranger
parentdev-util/cargo-nextest: mark ~arm (diff)
downloadgentoo-1d53662c70af773b63aa84915e74f634cf0ae3df.tar.gz
gentoo-1d53662c70af773b63aa84915e74f634cf0ae3df.tar.bz2
gentoo-1d53662c70af773b63aa84915e74f634cf0ae3df.zip
app-text/pdfarranger: updated DEPEND
Closes: https://bugs.gentoo.org/928962 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/pdfarranger')
-rw-r--r--app-text/pdfarranger/pdfarranger-1.10.1-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/pdfarranger/pdfarranger-1.10.1-r2.ebuild b/app-text/pdfarranger/pdfarranger-1.10.1-r2.ebuild
new file mode 100644
index 000000000000..5bb0d5ee7a7a
--- /dev/null
+++ b/app-text/pdfarranger/pdfarranger-1.10.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1 optfeature xdg desktop
+
+DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages"
+HOMEPAGE="https://github.com/jeromerobert/pdfarranger"
+SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/poppler[introspection,cairo]
+ dev-python/pikepdf[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},lcms]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ for x in 16 32 48 256 scalable
+ do doicon -s ${x} data/icons/hicolor/${x}*/*
+ done
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "image file import" media-gfx/img2pdf
+}