summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-03-06 21:05:59 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-03-06 21:06:32 +0700
commitc787dd77de0b67cab2d15a9bc7c85085eac143a0 (patch)
treec7105990502a3f3c9e11d0c1e3a41446dc97a8a5 /app-text/pdfarranger
parentdev-python/pymdown-extensions: Bump to 9.10 (diff)
downloadgentoo-c787dd77de0b67cab2d15a9bc7c85085eac143a0.tar.gz
gentoo-c787dd77de0b67cab2d15a9bc7c85085eac143a0.tar.bz2
gentoo-c787dd77de0b67cab2d15a9bc7c85085eac143a0.zip
app-text/pdfarranger: bump to 1.9.2
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/pdfarranger')
-rw-r--r--app-text/pdfarranger/Manifest1
-rw-r--r--app-text/pdfarranger/pdfarranger-1.9.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/pdfarranger/Manifest b/app-text/pdfarranger/Manifest
index 1647ec34ce7a..0b264609101a 100644
--- a/app-text/pdfarranger/Manifest
+++ b/app-text/pdfarranger/Manifest
@@ -1 +1,2 @@
DIST pdfarranger-1.9.1.tar.gz 279138 BLAKE2B 18ac9a63eff5455e395b3c126adea590b230b1884ee64e08eeaf4951c663787a827e42db9475632210b2ca3875a23e1718fdfc1b4309c5babc7ce31b6e188829 SHA512 ba60744f1b7c96ca9f86ed75cc5ea1b3df41af162048550a916a96972b0e987acfbdc3c46693adc239fdad5569369f24555e157a2f56936374ba132ffc8cbde6
+DIST pdfarranger-1.9.2.tar.gz 280531 BLAKE2B 6a7a8e73e701fe9bbb5bd1f94411003dfb16966ad28522820a27e7ab554b3c2679eec3f4a08332bd58dc1c1cafd620e1daef2f39cb0f6dc5589d7bd5eb293650 SHA512 c22cc753e2606d90913970ce57462b4aca7c41fa6a9b6ece76b618800cad12bce808aba4a6fba2ef9698fda209e11799f30d091a88c9beb2e80a09ac7df51cb8
diff --git a/app-text/pdfarranger/pdfarranger-1.9.2.ebuild b/app-text/pdfarranger/pdfarranger-1.9.2.ebuild
new file mode 100644
index 000000000000..44893f0ef11c
--- /dev/null
+++ b/app-text/pdfarranger/pdfarranger-1.9.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 optfeature xdg desktop
+
+DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages"
+HOMEPAGE="https://github.com/jeromerobert/pdfarranger"
+SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler[introspection,cairo]
+ >=dev-python/pikepdf-6.0.0[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ dev-util/intltool
+"
+
+src_install() {
+ distutils-r1_src_install
+ for x in 16 32 48 256 scalable
+ do doicon -s ${x} data/icons/hicolor/${x}*/*
+ done
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "image file import" media-gfx/img2pdf
+}