summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2019-03-20 20:32:14 +0100
committerDirkjan Ochtman <djc@gentoo.org>2019-03-20 20:32:31 +0100
commit66900222b11c12ffbbf96fd9c5741f2256d339c1 (patch)
treef1f591e831847460edf1b3435ae044c0f946849d /app-text/pelican
parentnet-firewall/shorewall: bump to v5.2.3.2 (diff)
downloadgentoo-66900222b11c12ffbbf96fd9c5741f2256d339c1.tar.gz
gentoo-66900222b11c12ffbbf96fd9c5741f2256d339c1.tar.bz2
gentoo-66900222b11c12ffbbf96fd9c5741f2256d339c1.zip
app-text/pelican: version bump to 4.0.0
Closes: https://bugs.gentoo.org/show_bug.cgi?id=671896 Signed-off-by: Dirkjan Ochtman <djc@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/Manifest1
-rw-r--r--app-text/pelican/pelican-4.0.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-text/pelican/Manifest b/app-text/pelican/Manifest
index e6d71aa5bff6..3d25b1d1c01b 100644
--- a/app-text/pelican/Manifest
+++ b/app-text/pelican/Manifest
@@ -2,3 +2,4 @@ DIST pelican-3.6.0.tar.gz 773887 BLAKE2B 9e0827a13fc1668a718c69604c29832062d69db
DIST pelican-3.6.3.tar.gz 775060 BLAKE2B b4e2ab53f312f4a6f0a3398dd07512e9e51f3f780dae47a7a2405f36ac81149eb336e8a97a7898dfdec9d27938acd57ebaa19b4d9f928f7c714cb9b85108dda6 SHA512 8bd8fcb72e67955d9c267731f74905417174d0767ec159d9b141e74aaa3cd8ee095270a7cc30847c413c702944df0c0b974ff8e98c55aa5004c00dbc55eadb16
DIST pelican-3.7.0.tar.gz 784432 BLAKE2B 34aac3c79fb4f9417132209ba2decb75b52aab80efa7a1770650422e283fe1801aedc68a84f2ec8ee36e3b3df67b0582ceb2062bf3dca2ba109bf76a8f462e06 SHA512 e4b8a771737a8f6fab109b0f4544229f09141f38210b502f605ae449be7ba12bb43db6637592d2e9060255e923f092c6cfe8dc7bbeec1431d5b625f3a9b8222d
DIST pelican-3.7.1.tar.gz 784605 BLAKE2B 42adef016f54a931e4fef225af9a4c5c880b66c96660c2a34137a425f879688822ddc8bbc19805444bf2b49369c3dccf8a5303748ff9e7cbde3910d6ba501652 SHA512 9e04e6a2009cc134f74410d8c8349831467192e7524287e23cad0b68232f2b5dd04f5d98505222d71eb3441e466bccec1cafc7f6e3c6bfcb4c5e57e4ab0fadda
+DIST pelican-4.0.0.tar.gz 1314626 BLAKE2B 18924209949b43063416f2e2c6e22a5524a36bab79a801f7cc6953c0822beb1bd5b05e715f5bcdb7c4877aba8d7a62cf4276e8abc43406f3c6fd7af8ef0c7c2f SHA512 5d98f5e13e6dde6b27cc299f9fb166edec79efb3fc53b29567218e0d0ba164989ce51830029ec8359697bc039661f6b0ced8d4155105e29098c038840c97d253
diff --git a/app-text/pelican/pelican-4.0.0.ebuild b/app-text/pelican/pelican-4.0.0.ebuild
new file mode 100644
index 000000000000..568df33717e0
--- /dev/null
+++ b/app-text/pelican/pelican-4.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to generate a static blog, with restructured text or markdown input files"
+HOMEPAGE="https://blog.getpelican.com/ https://pypi.org/project/pelican/"
+SRC_URI="https://github.com/getpelican/pelican/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples markdown test"
+
+DEPEND=">=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+RESTRICT="test"
+
+DOCS=( README.rst )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ docompress -x "/usr/share/doc/${PF}/samples"
+ doins -r samples
+ fi
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}