summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-02-11 15:54:35 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-02-11 15:55:41 +0900
commit94ed39336ee31fd1033b932fe0f68e196a614b33 (patch)
tree6420dd6e1d7815853c72be12048dc0de3ced8e70 /app-text/po4a
parentapp-text/po4a: drop old (diff)
downloadgentoo-94ed39336ee31fd1033b932fe0f68e196a614b33.tar.gz
gentoo-94ed39336ee31fd1033b932fe0f68e196a614b33.tar.bz2
gentoo-94ed39336ee31fd1033b932fe0f68e196a614b33.zip
app-text/po4a: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-text/po4a')
-rw-r--r--app-text/po4a/Manifest1
-rw-r--r--app-text/po4a/files/po4a-man.patch18
-rw-r--r--app-text/po4a/po4a-0.70.ebuild54
3 files changed, 73 insertions, 0 deletions
diff --git a/app-text/po4a/Manifest b/app-text/po4a/Manifest
index 0ddb49ce040b..aae62e6ad8bd 100644
--- a/app-text/po4a/Manifest
+++ b/app-text/po4a/Manifest
@@ -1,2 +1,3 @@
DIST po4a-0.66.tar.gz 4240059 BLAKE2B 1d88665b8aa0d7f81854c97265f483934adc51503c2d33252d6ae08a00fddfa8aaa6e9c652f764ae46bf14fea3bcd1093f923fcbf08d96e97296954199e9b900 SHA512 f72e1267cbd6ced01ecc362c327b1634c47dff15398b48644548d28e01ba91108d5626e6d4abcfcb360697e4c0affa3228c6993653ce8f257acbbb3d7ae20fc4
DIST po4a-0.69.tar.gz 4665710 BLAKE2B 2fc1b6cd53f1b282f20cd4932de7f5d6d9882de9f50181f0de89995c9d9b79b5fd2bc53d3757c56c519478e67ac636deb5a011cc8810a002b6bb6dabdb44442b SHA512 9cb5eec547ab18d1c3ebdda212b909fc4f5489a74641ba2d7e0a3a1d060f245d23667c16e687c678c5ccc3809c9315d20673266dcc3764172a899caa397238e3
+DIST po4a-0.70.tar.gz 4832825 BLAKE2B 2cf103cf95860855c8cd3e6090a75fce0791a58badc3a5bae0563c4d9b063af984fda1de5566d61caa23766ebddb66f8fb0a4701bfbc6fe2aafdf2bab292ef26 SHA512 2f12d9b9214b08bb7dd2d864016063845f397d7b71c1aa2292c1da1b71f1ec435cfae527032f4d6610d15d1a6ea40e35165dcba007b75cab635dd722cbc05139
diff --git a/app-text/po4a/files/po4a-man.patch b/app-text/po4a/files/po4a-man.patch
new file mode 100644
index 000000000000..b166887283cb
--- /dev/null
+++ b/app-text/po4a/files/po4a-man.patch
@@ -0,0 +1,18 @@
+--- a/Po4aBuilder.pm
++++ b/Po4aBuilder.pm
+@@ -242,7 +242,6 @@
+ }
+ $parser->parse_from_file( $file, $out );
+
+- system("gzip -9 -n -f $out") and die;
+ unlink "$file" || die;
+ }
+
+@@ -264,7 +263,6 @@
+ print "Convert $outdir/$outfile.$section (online docbook.xsl file). ";
+ system("xsltproc -o $outdir/$outfile.$section --nonet $docbook_xsl_url $file") and die;
+ }
+- system("gzip -9 -n -f $outdir/$outfile.$section") and die;
+ }
+ unlink "$file" || die;
+ }
diff --git a/app-text/po4a/po4a-0.70.ebuild b/app-text/po4a/po4a-0.70.ebuild
new file mode 100644
index 000000000000..5b80c728dbb4
--- /dev/null
+++ b/app-text/po4a/po4a-0.70.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PLOCALES="ace af ar ca cs da de eo es et eu fr hr hu id it ja ka kn ko nb nl pl pt pt_BR ru sl sr_Cyrl sv uk vi zh_Hans zh_Hant"
+
+inherit perl-module plocale
+
+DESCRIPTION="Tools to ease the translation of documentation"
+HOMEPAGE="https://po4a.org/"
+SRC_URI="https://github.com/mquinson/${PN}/files/14077820/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-text/opensp
+ dev-libs/libxslt
+ dev-perl/Locale-gettext
+ dev-perl/Pod-Parser
+ dev-perl/SGMLSpm
+ dev-perl/Syntax-Keyword-Try
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N
+ dev-perl/Unicode-LineBreak
+ dev-perl/YAML-Tiny
+ sys-devel/gettext"
+DEPEND="${RDEPEND}"
+BDEPEND="app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-perl/Module-Build
+ sys-devel/gettext
+ test? (
+ app-text/docbook-sgml-dtd:4.1
+ dev-perl/Test-Pod
+ virtual/latex-base
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-man.patch )
+
+DIST_TEST="do"
+
+src_prepare() {
+ plocale_find_changes "${S}/po/bin" '' '.po'
+
+ rm_locale() {
+ PERL_RM_FILES+=( po/{bin,pod}/${1}.po )
+ }
+ plocale_for_each_disabled_locale rm_locale
+
+ perl-module_src_prepare
+}