summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2023-01-04 02:57:24 +0100
committerJonas Stein <jstein@gentoo.org>2023-01-04 03:04:59 +0100
commit4db2fc21090abb424b8b2751eb0993139ac9ded4 (patch)
tree7b1cfcba067affefee71b6ab3be2f594e5bf5dd7 /app-text/tree
parentsys-process/minicoredumper: quote var (diff)
downloadgentoo-4db2fc21090abb424b8b2751eb0993139ac9ded4.tar.gz
gentoo-4db2fc21090abb424b8b2751eb0993139ac9ded4.tar.bz2
gentoo-4db2fc21090abb424b8b2751eb0993139ac9ded4.zip
app-text/tree: add 2.1.0
Version bump and migrate to bz2 compression in SRC_URI Suggested-by: Alexander Kurakin <kuraga333@mail.ru> Closes: https://bugs.gentoo.org/889540 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'app-text/tree')
-rw-r--r--app-text/tree/Manifest1
-rw-r--r--app-text/tree/tree-2.1.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/tree/Manifest b/app-text/tree/Manifest
index 76b3048e64d1..bdbfe971a219 100644
--- a/app-text/tree/Manifest
+++ b/app-text/tree/Manifest
@@ -1 +1,2 @@
DIST unix-tree-2.0.4.tar.gz 59497 BLAKE2B c55f8f64f2dfc6364ce3ab5ec26e59860f958eacbf681d1d53848172d474605f71864c1eb7db27be15f3df2fc2979787685e80de76ff817c5cdfafb9c52af203 SHA512 59f391de5792ce9990153c2de06bc545813f9e7aea635c574ef21f1603203146cdad4dbed821266715d716241d7153276aa220626ce8354446dd85df47e75fa6
+DIST unix-tree-2.1.0.tar.bz2 51401 BLAKE2B 89b15df0268c03ba66827c7e6d234d1f5c4f6a5d9788e30bf6859d477b340393acbeec9ad7afc1909fdc7beb81ef7934917206066e0875d9f1662fca170f4127 SHA512 0f3a6ecb450bb3d683804667d4f15aecf9c9765578d47a62e39a8ff69cbe1c2a0a4a922fef3728359060338f4f9cd2de7ab8eb0f992a4c32949278bb47d17edc
diff --git a/app-text/tree/tree-2.1.0.ebuild b/app-text/tree/tree-2.1.0.ebuild
new file mode 100644
index 000000000000..fbad3d309fd4
--- /dev/null
+++ b/app-text/tree/tree-2.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic bash-completion-r1
+
+DESCRIPTION="Lists directories recursively, and produces an indented listing of files"
+HOMEPAGE="https://mama.indstate.edu/users/ice/tree/ https://gitlab.com/OldManProgrammer/unix-tree"
+SRC_URI="https://gitlab.com/OldManProgrammer/unix-${PN}/-/archive/${PV}/unix-${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+S=${WORKDIR}/unix-${P}
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ if use !elibc_glibc ; then
+ # 433972, also previously done only for elibc_uclibc
+ sed -i -e '/^OBJS=/s/$/ strverscmp.o/' Makefile || die
+ fi
+ default
+}
+
+src_compile() {
+ append-lfs-flags
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin tree
+ doman doc/tree*.1
+ einstalldocs
+ newbashcomp "${FILESDIR}"/${PN}.bashcomp ${PN}
+}