summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2022-09-25 21:19:25 -0400
committerAnthony G. Basile <blueness@gentoo.org>2022-09-25 21:19:25 -0400
commit0e47c7fdca046db5ec0b34553ba103f2ae26e92b (patch)
treee69b21d48e459a56b0168c8181058183937ac3d6 /app-text/xapian-omega
parentdev-libs/xapian-bindings: version bump 1.4.21 (diff)
downloadgentoo-0e47c7fdca046db5ec0b34553ba103f2ae26e92b.tar.gz
gentoo-0e47c7fdca046db5ec0b34553ba103f2ae26e92b.tar.bz2
gentoo-0e47c7fdca046db5ec0b34553ba103f2ae26e92b.zip
app-text/xapian-omega: version bump 1.4.21
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'app-text/xapian-omega')
-rw-r--r--app-text/xapian-omega/Manifest1
-rw-r--r--app-text/xapian-omega/xapian-omega-1.4.21.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-text/xapian-omega/Manifest b/app-text/xapian-omega/Manifest
index 8fb023090246..b8778a8c7620 100644
--- a/app-text/xapian-omega/Manifest
+++ b/app-text/xapian-omega/Manifest
@@ -2,3 +2,4 @@ DIST xapian-omega-1.4.17.tar.xz 547372 BLAKE2B d164ee2f96d395e2a45919aea821d1bae
DIST xapian-omega-1.4.18.tar.xz 549892 BLAKE2B 440f7ac93acca5803c80d905a90db854f36a5fb1e486d5178c25db0490bc01812f2173feb8abb97a2e399449950524db7b557b303c671d1e9a50f062f332008a SHA512 35da36bdaa6997353554604db5ced3f3a05d0862ce5cf357fae639ca88a65ea83bf0be039629e6aedd67f8cb369a7eaeba7f279980c9e2f585083c737c61ea43
DIST xapian-omega-1.4.19.tar.xz 553680 BLAKE2B 1008376d2ba6d72d3cc267ee3bda78a1d37491d706417010e0f4ca7dddf78ddd3d9ad07108874eabfffd0280016ce1fad49c86ee89eed9b37ae571586f838c9b SHA512 82b682bc9d244256afffc2ab1b12b0f577184296a979dc42b2865b689c6d46eca6b838b95a5d040dc228de0c2e2261e81279e0a748eaff2d018732ce4bc07fae
DIST xapian-omega-1.4.20.tar.xz 563324 BLAKE2B 3836cc1f219f228edbd910dd92eb5bf7f91c6e0e5a1be2fad271dc9246ef0e5dd68d99d48f15c8ac9c449112d492e3becd501413a8c190d0b611d2506f8d82cb SHA512 026ca234d072da39a29d47b5b53033ec7677d51f93a6fedffb2a57ff5b788cc08d94d1dc43ff8c0062639470b8fe3150781008e4b50abd3ec5526b2b98a3a676
+DIST xapian-omega-1.4.21.tar.xz 568440 BLAKE2B 445152c23f58471402d8017906083123c0a0e55eb8feed8908dae46680148471a65c51ef146c693cbbb807ce7a70d6589c0a77c2508c39417b95f292d5e8b9f1 SHA512 a313725084c3c336655a3beaa2c1e6c9186027bf6c90f0c5261f748a08e1e8d1ef9d43b0c6bad5bbd5a5af9d1f3db49b915435e5e815f9e97d452590522e85ec
diff --git a/app-text/xapian-omega/xapian-omega-1.4.21.ebuild b/app-text/xapian-omega/xapian-omega-1.4.21.ebuild
new file mode 100644
index 000000000000..91ff25791e25
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.4.21.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
+HOMEPAGE="https://xapian.org/"
+S="${WORKDIR}/xapian-omega-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="~dev-libs/xapian-${PV}:0/30
+ dev-lang/perl
+ dev-libs/libpcre
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${ED}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}