summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-19 01:36:59 +0000
committerSam James <sam@gentoo.org>2023-03-19 01:36:59 +0000
commitef29c9b267893b579cb2437f62042cbedd634667 (patch)
treecdb580abcc15bd21ebaffcb0dbd25a3aad229299 /app-text/xml2doc
parentsys-devel/autoconf-archive: Stabilize 2023.02.20 ALLARCHES, #902097 (diff)
downloadgentoo-ef29c9b267893b579cb2437f62042cbedd634667.tar.gz
gentoo-ef29c9b267893b579cb2437f62042cbedd634667.tar.bz2
gentoo-ef29c9b267893b579cb2437f62042cbedd634667.zip
app-text/xml2doc: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/900539 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/xml2doc')
-rw-r--r--app-text/xml2doc/xml2doc-20030510-r2.ebuild (renamed from app-text/xml2doc/xml2doc-20030510-r1.ebuild)18
1 files changed, 12 insertions, 6 deletions
diff --git a/app-text/xml2doc/xml2doc-20030510-r1.ebuild b/app-text/xml2doc/xml2doc-20030510-r2.ebuild
index 919ecba3c27c..471710170ee3 100644
--- a/app-text/xml2doc/xml2doc-20030510-r1.ebuild
+++ b/app-text/xml2doc/xml2doc-20030510-r2.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Tool to convert simple XML to a variety of formats (pdf, html, txt, manpage)"
HOMEPAGE="http://xml2doc.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
@@ -16,17 +17,22 @@ KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
DEPEND="dev-libs/libxml2:2"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}"
-
PATCHES=(
# Fix pointer-related bug detected by a QA notice
"${FILESDIR}"/${PN}-pointer_fix.patch
# Don't strip symbols from binary (bug #152266)
"${FILESDIR}"/${P}-makefile.patch
- # fix GCC 10 -fno-common change
+ # Fix GCC 10 -fno-common change
"${FILESDIR}"/${P}-gcc10-no-common.patch
)
+src_prepare() {
+ default
+
+ # Clang 16, bug #900539
+ eautoreconf
+}
+
src_configure() {
tc-export CC
econf --disable-pdf