summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/xmldiff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/xmldiff')
-rw-r--r--app-text/xmldiff/Manifest1
-rw-r--r--app-text/xmldiff/metadata.xml14
-rw-r--r--app-text/xmldiff/xmldiff-0.6.10-r1.ebuild23
-rw-r--r--app-text/xmldiff/xmldiff-0.6.10.ebuild25
4 files changed, 63 insertions, 0 deletions
diff --git a/app-text/xmldiff/Manifest b/app-text/xmldiff/Manifest
new file mode 100644
index 000000000000..ab1ecc73e82b
--- /dev/null
+++ b/app-text/xmldiff/Manifest
@@ -0,0 +1 @@
+DIST xmldiff-0.6.10.tar.gz 45827 SHA256 83aba252df2f760c8bf008b9c5d3080911eab2d2b39c371d3b47f67abf4b4ec5 SHA512 b183a6e94258c4d693fa97e759868dae2dca6088e3cf12cf08b40e82d18a375f02b12d62d0cfc03fb74a5138f32f6614f555b95a3062ba768d1cdaf3391cc95b WHIRLPOOL f96431ae21277ef3d1ebf3246b65a6b488159c593b6ca8329aed28b9d67c64cab69a7697aecd2150f7e7410a2fef7c6127059b992adae45ae35f07ff964fef8c
diff --git a/app-text/xmldiff/metadata.xml b/app-text/xmldiff/metadata.xml
new file mode 100644
index 000000000000..d99df64178dd
--- /dev/null
+++ b/app-text/xmldiff/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <longdescription>A python tool that figures out the differences between two
+ similar XML files, in the same way the diff utility does.
+ Xmldiff was initially developed for the Narval project and could also be
+ used as a library or as a command line tool. It can work either with XML
+ files or DOM trees.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-text/xmldiff/xmldiff-0.6.10-r1.ebuild b/app-text/xmldiff/xmldiff-0.6.10-r1.ebuild
new file mode 100644
index 000000000000..2fa4e475152b
--- /dev/null
+++ b/app-text/xmldiff/xmldiff-0.6.10-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool that figures out the differences between two similar XML files"
+HOMEPAGE="http://www.logilab.org/project/xmldiff"
+SRC_URI="ftp://ftp.logilab.fr/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/pyxml[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog README README.xmlrev TODO )
diff --git a/app-text/xmldiff/xmldiff-0.6.10.ebuild b/app-text/xmldiff/xmldiff-0.6.10.ebuild
new file mode 100644
index 000000000000..ffbaaaa741a2
--- /dev/null
+++ b/app-text/xmldiff/xmldiff-0.6.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils python
+
+DESCRIPTION="A tool that figures out the differences between two similar XML files"
+HOMEPAGE="http://www.logilab.org/project/xmldiff"
+SRC_URI="ftp://ftp.logilab.fr/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86 ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/pyxml"
+RDEPEND="${DEPEND}"
+
+DOCS="ChangeLog README README.xmlrev TODO"