summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-04 07:54:23 +0000
committerSam James <sam@gentoo.org>2021-03-05 18:00:39 +0000
commitacdb9f34dd518c28727a3bfcfe1ff83eb5c999a0 (patch)
tree2853c0513ef9d4ff8de65604bcfe649cb3d9d8f7 /app-text/xmlformat
parentapp-shells/localshell: port to EAPI 7 (fix DeprecatedEclass) (diff)
downloadgentoo-acdb9f34dd518c28727a3bfcfe1ff83eb5c999a0.tar.gz
gentoo-acdb9f34dd518c28727a3bfcfe1ff83eb5c999a0.tar.bz2
gentoo-acdb9f34dd518c28727a3bfcfe1ff83eb5c999a0.zip
app-text/xmlformat: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/xmlformat')
-rw-r--r--app-text/xmlformat/xmlformat-1.04.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/app-text/xmlformat/xmlformat-1.04.ebuild b/app-text/xmlformat/xmlformat-1.04.ebuild
index 044ee876c257..7e10ca1cc039 100644
--- a/app-text/xmlformat/xmlformat-1.04.ebuild
+++ b/app-text/xmlformat/xmlformat-1.04.ebuild
@@ -1,30 +1,30 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
USE_RUBY="ruby24 ruby25 ruby26"
-
inherit ruby-single
DESCRIPTION="Reformat XML documents to your custom style"
SRC_URI="http://www.kitebird.com/software/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.kitebird.com/software/xmlformat/"
-SLOT="0"
LICENSE="xmlformat"
+SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc ruby"
-DEPEND="ruby? ( ${RUBY_DEPS} )
- !ruby? ( dev-lang/perl )"
-RDEPEND=${DEPEND}
-IUSE="ruby doc"
+DEPEND="
+ ruby? ( ${RUBY_DEPS} )
+ !ruby? ( dev-lang/perl )
+"
+RDEPEND="${DEPEND}"
src_install() {
dobin xmlformat.pl
- if use ruby
- then
+ if use ruby; then
dobin xmlformat.rb
dosym xmlformat.rb /usr/bin/xmlformat
else
@@ -33,17 +33,14 @@ src_install() {
dodoc BUGS ChangeLog README TODO
- if use doc
- then
+ if use doc; then
# APIs
- insinto /usr/share/doc/${PF}
- doins -r docs/*
+ dodoc -r docs/*
fi
}
src_test() {
- if use ruby
- then
+ if use ruby; then
./runtest all || die "runtest for ruby failed."
else
./runtest -p all || die "runtest for perl failed."