summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-09-02 15:05:57 +0200
committerSebastian Pipping <sping@gentoo.org>2022-09-02 15:05:57 +0200
commitcd06c9384096477b8dcfe3c12ec27f3c2c293d9d (patch)
tree2d5464b3e4caa606e1f7b28664d631dfe1f16e42 /app-text/xmlstarlet
parentmedia-gfx/fotoxx: drop 22.16, 22.18, 22.30 (diff)
downloadgentoo-cd06c9384096477b8dcfe3c12ec27f3c2c293d9d.tar.gz
gentoo-cd06c9384096477b8dcfe3c12ec27f3c2c293d9d.tar.bz2
gentoo-cd06c9384096477b8dcfe3c12ec27f3c2c293d9d.zip
app-text/xmlstarlet: Fix compile for libdir "lib"
Closes: https://bugs.gentoo.org/830062 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'app-text/xmlstarlet')
-rw-r--r--app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild b/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
index 37ed9694ee5f..a234631ef8b8 100644
--- a/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
+++ b/app-text/xmlstarlet/xmlstarlet-1.6.1.ebuild
@@ -28,9 +28,11 @@ src_prepare() {
# linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/729600).
# The grep sandwich acts as a regression test so that a future
# version bump cannot break patching without noticing.
- grep -wq _PREFIX/lib m4/xstar-check-libs.m4 || die
- sed "s,_PREFIX/lib,_PREFIX/$(get_libdir)," -i m4/xstar-check-libs.m4 || die
- grep -w _PREFIX/lib m4/xstar-check-libs.m4 && die
+ if [[ $(get_libdir) != lib ]]; then
+ grep -wq _PREFIX/lib m4/xstar-check-libs.m4 || die
+ sed "s,_PREFIX/lib,_PREFIX/$(get_libdir)," -i m4/xstar-check-libs.m4 || die
+ grep -w _PREFIX/lib m4/xstar-check-libs.m4 && die
+ fi
eautoreconf
}