summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-21 22:43:30 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-21 22:48:48 -0700
commit14f6501f0a9fd475554ba848160cf17ee5158185 (patch)
tree20eab84ed88af58a6525e156e99cb475928f656f /app-text/yelp-tools
parentgnome-extra/yelp-xsl: Version bump to 42.0 (diff)
downloadgentoo-14f6501f0a9fd475554ba848160cf17ee5158185.tar.gz
gentoo-14f6501f0a9fd475554ba848160cf17ee5158185.tar.bz2
gentoo-14f6501f0a9fd475554ba848160cf17ee5158185.zip
app-text/yelp-tools: Version bump to 42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text/yelp-tools')
-rw-r--r--app-text/yelp-tools/Manifest1
-rw-r--r--app-text/yelp-tools/yelp-tools-42.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-text/yelp-tools/Manifest b/app-text/yelp-tools/Manifest
index 10d1fdc649fd..e6f379dca699 100644
--- a/app-text/yelp-tools/Manifest
+++ b/app-text/yelp-tools/Manifest
@@ -1 +1,2 @@
DIST yelp-tools-41.0.tar.xz 38696 BLAKE2B 6e742e0a5c05c07fb3eb80fc10201650597fb36702edb1d9fc022895daf2837daed15a2b69b8bed7aaf0106139c7138e8f13b65b63cf18971e14eaeb0068b061 SHA512 76b8f9568942426698716d655bc2e7a614a26e40a820d1f4ce5021a54c6baa081d494bda06657cfc1c11999e14a8601c97ae51bb3519555b8ee1111489c0e10e
+DIST yelp-tools-42.0.tar.xz 38788 BLAKE2B 9dc34f4b32c9e705f427bccad5ff3c2cd222a1391a780dde145ea894e1065fc873fd4ef020d1b7809b653c8237fbedb7f0b07d684d8d906b7af7a0fd8ebf79e4 SHA512 ff6168a33b2dedd12f7fb5d5aa6394a554b7ad8956cc7121e5f1a520f9fb20bd4cad93e22b5e8b2f8aa82ca5a1711a0634d8619c731e46730084e28f29725786
diff --git a/app-text/yelp-tools/yelp-tools-42.0.ebuild b/app-text/yelp-tools/yelp-tools-42.0.ebuild
new file mode 100644
index 000000000000..24a0d5b029d9
--- /dev/null
+++ b/app-text/yelp-tools/yelp-tools-42.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome2 meson python-single-r1
+
+DESCRIPTION="Collection of tools for building and converting documentation"
+HOMEPAGE="https://wiki.gnome.org/Apps/Yelp/Tools"
+
+LICENSE="|| ( GPL-2+ freedist ) GPL-2+" # yelp.m4 is GPL2 || freely distributable
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]')
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.8
+ dev-util/itstool
+ >=gnome-extra/yelp-xsl-3.38
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"/usr/bin/yelp-{build,check,new}
+}