summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-04-22 10:22:54 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-04-22 10:23:12 +0200
commit8d6b385122ab9c1bbe0dc3a6a3053d91d36a7560 (patch)
tree1a60f7501188206a1a56f69514b110237942b5b5 /app-text/zotero-bin
parentdev-python/PyQt6: simplify using python_configure_all (diff)
downloadgentoo-8d6b385122ab9c1bbe0dc3a6a3053d91d36a7560.tar.gz
gentoo-8d6b385122ab9c1bbe0dc3a6a3053d91d36a7560.tar.bz2
gentoo-8d6b385122ab9c1bbe0dc3a6a3053d91d36a7560.zip
app-text/zotero-bin: add 6.0.26
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-text/zotero-bin')
-rw-r--r--app-text/zotero-bin/Manifest2
-rw-r--r--app-text/zotero-bin/zotero-bin-6.0.26.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
index 752f36911aac..9181c557205d 100644
--- a/app-text/zotero-bin/Manifest
+++ b/app-text/zotero-bin/Manifest
@@ -2,3 +2,5 @@ DIST zotero-bin-6.0.23-amd64.tar.bz2 69289934 BLAKE2B a002cda6337c0e1145628abb27
DIST zotero-bin-6.0.23-x86.tar.bz2 70947747 BLAKE2B 47c5ff05ae41fbc1e75649a84af718dcac1cab65b1131529c903be29be9415e799d9465569901730bd55008d1e12502527fbb2c424ff9d386f5edb07c99bcbd7 SHA512 6e7d339f7ea56862fe0ba9501a4c3f671991d8e93e88c1e41d41141ad7e35ddf785ec4c4000267925f9276cab8c9e6dcfb92dcff19eec56a69e44ef1964d2c28
DIST zotero-bin-6.0.25-amd64.tar.bz2 69360758 BLAKE2B e5ab5824397a28f476e37b41aff240c79365f3767653016c6e46777ab6e2d857e4a03e354a1b6a5b9985c3d42d30e78ebfc31f725af056eb6d53e4c40d98f28d SHA512 2d2622a2847cfde94d2b33e2630078086b5121bd953ef0940aa05a2280f1c3c191932c16bf8fe122349b23905e3ff444c36cb6db407e211408040dcfcaf8eef9
DIST zotero-bin-6.0.25-x86.tar.bz2 71019373 BLAKE2B 0fb892141813774694956029b5ee3e716c623ac9f96a15e9ac429b066dd29206bc2a357330e9e2a0bac842be7fb228b9b7e440f373804654644a96cf962bccd3 SHA512 080535f72882ab32f2bc8050bcaa67f1b02796601be2b1dd5e1d4771c790105978f54b4e2d7a78c7e638f0268d26da60693953df13e2c964fdbb497f43cbbcd9
+DIST zotero-bin-6.0.26-amd64.tar.bz2 69362169 BLAKE2B 53a4ed494f3e68821960cd01dd5f13a8e91cf1165a26a4fc2893a721794fe2449b7b0cbbe5e9a9f91995f9dbd697ac4707e6db302bcc78cd63beff6aba65f9e0 SHA512 9939cd13549a4e446ea1d0433760767bd74500afbe3ba06e7f779fc710fa99dca8460d8445d574a08e44c0cbcd561a9ea76c8dfac028db8397405f9f48698102
+DIST zotero-bin-6.0.26-x86.tar.bz2 71020459 BLAKE2B 859392e9916c7b16c3501aaff913aa7353e240442ad25ba0f9c851e6adca8c5433dad9a07f99f43ea026e5040046ff3bb7f00181e4f9867e72cd0966e607de51 SHA512 a79b2da87db01c5975e924f36db5c855ae72bde6eba71e5a40c00b56d6f63eb7c02d0cefc8aced99c52f26f75a296907cf4b36f06cad3796436f164ff3275fc2
diff --git a/app-text/zotero-bin/zotero-bin-6.0.26.ebuild b/app-text/zotero-bin/zotero-bin-6.0.26.ebuild
new file mode 100644
index 000000000000..07c557e6c051
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-6.0.26.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="
+ amd64? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}-amd64.tar.bz2 )
+ x86? ( https://www.zotero.org/download/client/dl?channel=release&platform=linux-i686&version=${PV} -> ${P}-x86.tar.bz2 )
+"
+S="${WORKDIR}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ app-accessibility/at-spi2-core
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/zotero/*"
+
+src_prepare() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ # disable auto-update
+ sed -i -e 's/\(pref("app.update.enabled"\).*/\1, false);/' defaults/preferences/prefs.js || die
+
+ # disable default oo installation questions - manual installation is still possible
+ sed -i -e 's/\(pref("extensions.zoteroOpenOfficeIntegration.skipInstallation"\).*/\1, true);/' \
+ extensions/zoteroOpenOfficeIntegration@zotero.org/defaults/preferences/zoteroOpenOfficeIntegration.js || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero#' zotero.desktop || die
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop || die
+
+ default
+}
+
+src_install() {
+ if use amd64; then
+ cd Zotero_linux-x86_64 || die
+ elif use x86; then
+ cd Zotero_linux-i686 || die
+ fi
+
+ dodir opt/zotero
+ cp -a * "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 16 32 48 256; do
+ newicon -s ${size} chrome/icons/default/default${size}.png zotero.png
+ done
+}