summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/easy-align
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/easy-align')
-rw-r--r--app-vim/easy-align/Manifest2
-rw-r--r--app-vim/easy-align/easy-align-2.9.4.ebuild23
-rw-r--r--app-vim/easy-align/easy-align-2.9.6.ebuild23
-rw-r--r--app-vim/easy-align/metadata.xml8
4 files changed, 56 insertions, 0 deletions
diff --git a/app-vim/easy-align/Manifest b/app-vim/easy-align/Manifest
new file mode 100644
index 000000000000..62fa8d0d4647
--- /dev/null
+++ b/app-vim/easy-align/Manifest
@@ -0,0 +1,2 @@
+DIST easy-align-2.9.4.tar.gz 21247 SHA256 f01c57335acdd6982789e636aa9586417d39a991410882d82bacf3a2fd6491b5 SHA512 ba2f7f38202cb5ca959a40e8b1de37e3687577f71b39fb16765a8c50f8c1c51563375b34ae407e13874990ac5e9af8bbd9f36256b8a9563417b4f561adbb0f9a WHIRLPOOL 26d101fac05b3ccbee92b221be72ded5cce3a10872c4bd59dd7689c6faf992f1065490948b7c23545d75358927c734113a5772f2044a06df870f0a98792fd239
+DIST easy-align-2.9.6.tar.gz 21391 SHA256 212499ef4311b2dd7bd303f618c1b7e7b42396e2a7e13156d769d3f673c96e22 SHA512 ae351ef1789253ce541656dc455969148f9e8d28de3a44cd579eae7eff0e9cca1d89c508c60f5cead4e43e64038dd0c93a933a2e147ebdae1b98f0f4d2eaacc8 WHIRLPOOL 72de29a96882ca903eba5877666bb1a8eb11b7ba80034489f4d442aa96118bf5900ccd5b9fca4d08a32489af2ca4fa14e8e60db6b230de07f425093039207ea0
diff --git a/app-vim/easy-align/easy-align-2.9.4.ebuild b/app-vim/easy-align/easy-align-2.9.4.ebuild
new file mode 100644
index 000000000000..45c8f0b97f0e
--- /dev/null
+++ b/app-vim/easy-align/easy-align-2.9.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vim-plugin
+
+MY_PN=vim-${PN}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: a simple alignment plugin"
+HOMEPAGE="https://github.com/junegunn/vim-easy-align http://www.vim.org/scripts/script.php?script_id=4520"
+SRC_URI="https://github.com/junegunn/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ rmdir test || die
+}
diff --git a/app-vim/easy-align/easy-align-2.9.6.ebuild b/app-vim/easy-align/easy-align-2.9.6.ebuild
new file mode 100644
index 000000000000..45c8f0b97f0e
--- /dev/null
+++ b/app-vim/easy-align/easy-align-2.9.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vim-plugin
+
+MY_PN=vim-${PN}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: a simple alignment plugin"
+HOMEPAGE="https://github.com/junegunn/vim-easy-align http://www.vim.org/scripts/script.php?script_id=4520"
+SRC_URI="https://github.com/junegunn/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ rmdir test || die
+}
diff --git a/app-vim/easy-align/metadata.xml b/app-vim/easy-align/metadata.xml
new file mode 100644
index 000000000000..d49628a1bb96
--- /dev/null
+++ b/app-vim/easy-align/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">junegunn/vim-easy-align</remote-id>
+ </upstream>
+</pkgmetadata>