summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/omnicppcomplete
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/omnicppcomplete')
-rw-r--r--app-vim/omnicppcomplete/Manifest1
-rw-r--r--app-vim/omnicppcomplete/metadata.xml5
-rw-r--r--app-vim/omnicppcomplete/omnicppcomplete-0.41.ebuild23
3 files changed, 29 insertions, 0 deletions
diff --git a/app-vim/omnicppcomplete/Manifest b/app-vim/omnicppcomplete/Manifest
new file mode 100644
index 000000000000..3b6cbcf9100e
--- /dev/null
+++ b/app-vim/omnicppcomplete/Manifest
@@ -0,0 +1 @@
+DIST omnicppcomplete-0.41.zip 38331 SHA256 7f0f3e870674458548bf219cba70ae11a5a7076399ca3fc2380982b61fb9d2da SHA512 565703f0e21f818308dbfbfaaec981eb522621568dee5b021bb8fe243da464b1d7defa45dc1cc2ac3370b3b3c67fb39dcb0dd7a1535a4dfe2ad81218f4ac71f3 WHIRLPOOL 7c59b3f14d0727c9e157b26e82957b603dbdf324fcf8c98da50bf684a0c474f5c24ef1ca430a5802aa83d2e3e6b11cd66b8c6d54c0627e0dfeb6eaf73267ea19
diff --git a/app-vim/omnicppcomplete/metadata.xml b/app-vim/omnicppcomplete/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/omnicppcomplete/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>
diff --git a/app-vim/omnicppcomplete/omnicppcomplete-0.41.ebuild b/app-vim/omnicppcomplete/omnicppcomplete-0.41.ebuild
new file mode 100644
index 000000000000..347e72fc80ca
--- /dev/null
+++ b/app-vim/omnicppcomplete/omnicppcomplete-0.41.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+VIM_PLUGIN_VIM_VERSION="7.0"
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: C/C++ omni-completion with ctags database"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1520"
+SRC_URI="http://www.vim.org/scripts/download_script.php?src_id=7722 -> ${P}.zip"
+
+LICENSE="vim.org"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-util/ctags-5.7"
+
+S="${WORKDIR}"
+
+VIM_PLUGIN_HELPFILES="${PN}"