summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-08-17 23:25:44 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-17 23:26:02 +0200
commit29070e3f3eeae003a68ad48075d0ff87b8353da6 (patch)
tree395cd311e7bd298599dac1ebf664b30df5ec17e2 /app-vim/vim-hoogle
parentsys-libs/glibc: backport memchr() out-of-bounds fix to 2.25, bug #628100 (diff)
downloadgentoo-29070e3f3eeae003a68ad48075d0ff87b8353da6.tar.gz
gentoo-29070e3f3eeae003a68ad48075d0ff87b8353da6.tar.bz2
gentoo-29070e3f3eeae003a68ad48075d0ff87b8353da6.zip
app-vim/vim-hoogle: new package.
vim-hoogle is a plugin to call hoogle from within vim. Gentoo-Bug: https://bugs.gentoo.org/476354 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-vim/vim-hoogle')
-rw-r--r--app-vim/vim-hoogle/Manifest1
-rw-r--r--app-vim/vim-hoogle/metadata.xml11
-rw-r--r--app-vim/vim-hoogle/vim-hoogle-1.3.ebuild16
3 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/vim-hoogle/Manifest b/app-vim/vim-hoogle/Manifest
new file mode 100644
index 000000000000..a92ce0cc802b
--- /dev/null
+++ b/app-vim/vim-hoogle/Manifest
@@ -0,0 +1 @@
+DIST vim-hoogle-1.3.tar.gz 3337 SHA256 e1a9b3d9f0741cec04d59cc8ce7806a0e801236e4f25b06d508270bd3b01d2a4 SHA512 ea0d2b723e913836dbff5947e7de4fb5dda19ab1d3bd51cd315b28499f1b6c771b037b16eec6a88862d27f675a9ddac11eb5d8d5a5b3ee3e2eeb7620ed4d565a WHIRLPOOL 641109deddbde97f4d31e3542256e392f72845239f235710b877bad06efd2af9ec9e3718ba7797f01bd8b8c461bef7491a195a3695e773c0a1b9744a52fae1d4
diff --git a/app-vim/vim-hoogle/metadata.xml b/app-vim/vim-hoogle/metadata.xml
new file mode 100644
index 000000000000..ee47616d507b
--- /dev/null
+++ b/app-vim/vim-hoogle/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Twinside/vim-hoogle</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-hoogle/vim-hoogle-1.3.ebuild b/app-vim/vim-hoogle/vim-hoogle-1.3.ebuild
new file mode 100644
index 000000000000..1dee86affdcf
--- /dev/null
+++ b/app-vim/vim-hoogle/vim-hoogle-1.3.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MASTER_COMMIT_HASH="31823f830843385f53a3da7a5bfaf678494383c4"
+
+DESCRIPTION="vim plugin: use hoogle within vim"
+HOMEPAGE="https://github.com/Twinside/vim-hoogle"
+SRC_URI="https://github.com/Twinside/${PN}/archive/${MASTER_COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim.org"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}-${MASTER_COMMIT_HASH}"