summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2018-12-24 18:31:20 -0700
committerDenis Dupeyron <calchan@gentoo.org>2018-12-24 18:31:20 -0700
commiteb40ecdb1560682ecd9d638b4881d682d0e58ec7 (patch)
tree055023194c0c42b9a9bc30af7be7ac1c8efb7f29 /app-vim
parentdev-python/PyQt5: update doc URL in metadata.xml (diff)
downloadgentoo-eb40ecdb1560682ecd9d638b4881d682d0e58ec7.tar.gz
gentoo-eb40ecdb1560682ecd9d638b4881d682d0e58ec7.tar.bz2
gentoo-eb40ecdb1560682ecd9d638b4881d682d0e58ec7.zip
app-vim/vim-go: bump to 1.19
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Denis Dupeyron <calchan@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vim-go/Manifest1
-rw-r--r--app-vim/vim-go/vim-go-1.19.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/vim-go/Manifest b/app-vim/vim-go/Manifest
index a4361b8989c1..60f40077f3ba 100644
--- a/app-vim/vim-go/Manifest
+++ b/app-vim/vim-go/Manifest
@@ -1 +1,2 @@
DIST vim-go-1.13.tar.gz 870173 BLAKE2B a2f67cef249191cf91caf45c120e471301a89ee365ba9add839edea17990ff3aba7238965dac1c71a89d2004dfcfd486319fc4f1474c7ee94d3845724cd9b289 SHA512 c2aa31104168f3a8e1f96b0ad2c51dc1c2e5a1de3db76f0009edfb38bf60ebfcd9bd8a86fedb6ff6d6d789973a557d6ed03e38e67159bc43c5231449b0253c25
+DIST vim-go-1.19.tar.gz 218988 BLAKE2B 3bbafde28342b8febc8763fe9858575abc8f3e9735f3886de508cb7986bd97d1d2eeb36bdd4eb9b2f514e74f47b08355549e32c101519dac41427f302f57e29f SHA512 fc2cdcbc58878ab435c6b253a226e46ca60083bfd4e6df683e1dbeb368bb25b10fc531630a6b1f6cbfc32306a255eb6eae6bcc3f7a7b770758d4beb71c539f77
diff --git a/app-vim/vim-go/vim-go-1.19.ebuild b/app-vim/vim-go/vim-go-1.19.ebuild
new file mode 100644
index 000000000000..af04db9720d6
--- /dev/null
+++ b/app-vim/vim-go/vim-go-1.19.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Go development plugin for Vim"
+HOMEPAGE="https://github.com/fatih/vim-go"
+SRC_URI="https://github.com/fatih/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="$PN"
+
+RESTRICT="test"
+
+src_compile() {
+ # safely skip `make test` triggered by `make` as it runs `go get` commands
+ # TODO: see :GoInstallBinaries (https://github.com/fatih/vim-go/blob/master/doc/vim-go.txt)
+ :;
+}