summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-10-03 14:34:29 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-10-03 14:34:29 +0200
commit10b21a9f0be402a67a16dedd4c0474681effd4f0 (patch)
treeffbd50f0f63ba27526293a83265509b52e57444c /dev-ada/gnat-suite-bin
parentapp-i18n/skk-jisyo: install docs (diff)
downloadgentoo-10b21a9f0be402a67a16dedd4c0474681effd4f0.tar.gz
gentoo-10b21a9f0be402a67a16dedd4c0474681effd4f0.tar.bz2
gentoo-10b21a9f0be402a67a16dedd4c0474681effd4f0.zip
dev-ada/gnat-suite-bin: Add gps suite binary and compiler
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada/gnat-suite-bin')
-rw-r--r--dev-ada/gnat-suite-bin/Manifest5
-rw-r--r--dev-ada/gnat-suite-bin/gnat-suite-bin-2014.ebuild111
-rw-r--r--dev-ada/gnat-suite-bin/gnat-suite-bin-2016.ebuild106
-rw-r--r--dev-ada/gnat-suite-bin/gnat-suite-bin-2017.ebuild106
-rw-r--r--dev-ada/gnat-suite-bin/gnat-suite-bin-2018.ebuild86
-rw-r--r--dev-ada/gnat-suite-bin/metadata.xml10
6 files changed, 424 insertions, 0 deletions
diff --git a/dev-ada/gnat-suite-bin/Manifest b/dev-ada/gnat-suite-bin/Manifest
new file mode 100644
index 000000000000..596defa1e822
--- /dev/null
+++ b/dev-ada/gnat-suite-bin/Manifest
@@ -0,0 +1,5 @@
+DIST gnat-gpl-2014-x86-linux-bin.tar.gz 233049287 BLAKE2B 2e8bab113f6a319533ec12fdf71c481f72aee227c22bd0cc42a53bd727b323caba1e7b6298053db8b4d3016236b31649b0b255f4ebcbb81a08a69f29f78f13fc SHA512 ac7f53fb4bd71b0e8fbd62abc45de76f7f8f2f405b80e9b60b4b65a6cef6ee98e3b06848e4b752af3c8268237e5a0529cf6145ebc5b33cd6e5cf4928d85f5be2
+DIST gnat-gpl-2014-x86_64-linux-bin.tar.gz 236253400 BLAKE2B c1db70db9442ba24688b8e323d5a02e2e9707ba1f02835ea551038d0a09aafede93a224091e5186f2f2a9d0f96144027af2184ee05ca1c19cc997a6cf3902df7 SHA512 5e40a251baac3d0ace78352956ca21a7d294d902d344a9ed7a8d376e900468c283721ebfb773adfedbf4d623ace02536505c0147815a0c1908933ad611ea085e
+DIST gnat-gpl-2016-x86_64-linux-bin.tar.gz 372813330 BLAKE2B a0374ad730ae275aaedcf5663c30f8e0221af32f14391fe87a3ce0630d4498a1e90671c02830d62f78857571a5a521af91f6db409a7b3c367c7b0f059571eefd SHA512 5115ac3be0badc5125ee048a98230f18363d72107da3325ce602c0e618cee2e3646a0decc00a2388f14bc61bfed51dd0622f365f5f7ee8b0cec2187ebcf8e075
+DIST gnat-gpl-2017-x86_64-linux-bin.tar.gz 496338280 BLAKE2B b3eee6d311fb9c20bc8fa7217c0731ca1e91ced38700df1d63d91a16c3fa28dfd44c7c8e867c3a857b88e4f0c8b2a7200fb6a8a630b8403538c4784f8914d1a5 SHA512 01a8f3be9b7b7e83cc5bd4a45137b1d35c6448bc22a88bcaf5d312cd63e11081b6b2fe9f09ad2a27d8f0b6471fc5c1a99573bf3bcee1589329054074eaeef04f
+DIST gnat-suite-bin-2018.txz 337235688 BLAKE2B cf1b8f0253907b8fc97b9c7218b23dcda8f1557be5e12293eab59e09427418a8814c1bafbcb3f89c1e5dd755a161c5dfa8a852631d137f17acb3167bf51dadbb SHA512 9b57709c05a121b0a0adabe3232128e3f27659d1928857fbd6883b73a7487c3d457317e8f236df3d16ced635514af8afbafc584cc74d865e11288820ac9c4f77
diff --git a/dev-ada/gnat-suite-bin/gnat-suite-bin-2014.ebuild b/dev-ada/gnat-suite-bin/gnat-suite-bin-2014.ebuild
new file mode 100644
index 000000000000..2a3719436715
--- /dev/null
+++ b/dev-ada/gnat-suite-bin/gnat-suite-bin-2014.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MYP=gnat-gpl-${PV}
+DESCRIPTION="GNAT Ada suite"
+HOMEPAGE="http://libre.adacore.com/"
+SRC_URI="
+ x86? ( http://mirrors.cdn.adacore.com/art/564b3e9dc8e196b040fbe248
+ -> ${MYP}-x86-linux-bin.tar.gz )
+ amd64? ( http://mirrors.cdn.adacore.com/art/564b3ebec8e196b040fbe66c
+ -> ${MYP}-x86_64-linux-bin.tar.gz )"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-devel/binutils
+ sys-devel/gdb"
+
+S="${WORKDIR}"
+
+PREFIX=/opt/${P}
+
+src_prepare() {
+ default
+ cd ${MYP}-$(usex amd64 x86_64 x86)-linux-bin
+ cd share/examples/gnat
+ cat header.xml \
+ full_project/full.xml \
+ options/options.xml \
+ other_languages/cpp_main/cpp_main.xml \
+ other_languages/cpp_pragmas/cpp_pragmas.xml \
+ other_languages/import_from_c/import_from_c.xml \
+ plugins/plugins.xml \
+ stream_io/stream_io.xml \
+ simple_project/simple.xml \
+ starter/starter.xml \
+ xml_stream/xml_stream.xml \
+ containers/anagram/anagram.xml \
+ containers/genealogy/genealogy.xml \
+ containers/hash/hash.xml \
+ containers/library/library.xml \
+ containers/shapes/shapes.xml \
+ containers/spellcheck/spellcheck.xml \
+ containers/wordcount/wordcount.xml \
+ containers/wordfreq/wordfreq.xml \
+ oo_interfaces/oo_interfaces.xml \
+ oo_airline/oo_airline.xml \
+ altivec/altivec.xml \
+ footer.xml \
+ > gnat-examples.xml \
+ || die
+ sed -i \
+ -e "s:PREFIX:${PREFIX}:" \
+ gnat-examples.xml || die
+ cd ../../..
+
+ # Remove objects from binutils
+ cd bin
+ rm addr2line c++filt gprof objdump || die
+ cd ..
+ rm share/doc/gnat/info/{as,bfd,binutils,ld}.info || die
+ rm lib*/libiberty.a || die
+
+ # Remove objects from gdb
+ cd bin
+ rm gdb gdbserver gcore || die
+ cd ..
+ rm -r include/gdb || die
+ rm lib*/libinproctrace.so || die
+ rm -r share/gdb-* || die
+ rm share/doc/gnat/info/gdb.info || die
+
+ basever=4.7.4
+ machine=$(usex amd64 x86_64 x86)-pc-linux-gnu
+ rm libexec//gcc/${machine}/${basever}/ld || die
+}
+
+src_install() {
+ cd ${MYP}-$(usex amd64 x86_64 x86)-linux-bin
+ into ${PREFIX}
+ dobin bin/*
+ insinto ${PREFIX}
+ doins -r etc include lib* share
+ insinto ${PREFIX}/share/gps/plug-ins
+ doins share/examples/gnat/gnat-examples.xml
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/cc1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/cc1plus || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/collect2 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/gnat1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/liblto_plugin.so.0.0.0 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/lto1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/lto-wrapper || die
+ fperms 755 ${PREFIX}/libexec/gprbuild/gprbind || die
+ fperms 755 ${PREFIX}/libexec/gprbuild/gprlib || die
+}
+
+pkg_postinst () {
+ einfo "GNAT GPL is now installed. To launch it, you must put"
+ einfo " ${PREFIX}/bin"
+ einfo "in front of your PATH environment variable. The following"
+ einfo "commands enable you to do this:"
+ einfo " PATH=${PREFIX}/bin:\$PATH; export PATH (Bourne shell)"
+ einfo " setenv PATH ${PREFIX}/bin:\$PATH (C shell)"
+ einfo " Thank you for installing GNAT GPL Edition"
+}
diff --git a/dev-ada/gnat-suite-bin/gnat-suite-bin-2016.ebuild b/dev-ada/gnat-suite-bin/gnat-suite-bin-2016.ebuild
new file mode 100644
index 000000000000..c8871ce504ba
--- /dev/null
+++ b/dev-ada/gnat-suite-bin/gnat-suite-bin-2016.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MYP=gnat-gpl-${PV}
+DESCRIPTION="GNAT Ada suite"
+HOMEPAGE="http://libre.adacore.com/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/5739cefdc7a447658e0b016b
+ -> ${MYP}-x86_64-linux-bin.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-devel/binutils
+ sys-devel/gdb"
+
+S="${WORKDIR}"/${MYP}-x86_64-linux-bin
+
+PREFIX=/opt/${P}
+
+src_prepare() {
+ default
+ rm Makefile
+ cd share/examples/gnat
+ cat header.xml \
+ full_project/full.xml \
+ options/options.xml \
+ other_languages/cpp_main/cpp_main.xml \
+ other_languages/cpp_pragmas/cpp_pragmas.xml \
+ other_languages/import_from_c/import_from_c.xml \
+ plugins/plugins.xml \
+ stream_io/stream_io.xml \
+ simple_project/simple.xml \
+ starter/starter.xml \
+ xml_stream/xml_stream.xml \
+ containers/anagram/anagram.xml \
+ containers/genealogy/genealogy.xml \
+ containers/hash/hash.xml \
+ containers/library/library.xml \
+ containers/shapes/shapes.xml \
+ containers/spellcheck/spellcheck.xml \
+ containers/wordcount/wordcount.xml \
+ containers/wordfreq/wordfreq.xml \
+ oo_interfaces/oo_interfaces.xml \
+ oo_airline/oo_airline.xml \
+ altivec/altivec.xml \
+ footer.xml \
+ > gnat-examples.xml \
+ || die
+ sed -i \
+ -e "s:PREFIX:${PREFIX}:" \
+ gnat-examples.xml || die
+ cd ../../..
+
+ # Remove objects from binutils
+ cd bin
+ rm addr2line ar c++filt gprof nm objdump ranlib || die
+ cd ..
+ rm share/doc/gnat/info/{as,bfd,binutils,ld}.info || die
+
+ # Remove objects from gdb
+ cd bin
+ rm gdb gdbserver gcore || die
+ cd ..
+ rm -r include/gdb || die
+ rm lib*/libinproctrace.so || die
+ rm -r share/gdb-* || die
+ rm share/doc/gnat/info/gdb.info || die
+
+ basever=4.9.4
+ machine=x86_64-pc-linux-gnu
+ rm libexec//gcc/${machine}/${basever}/ld || die
+}
+
+src_install() {
+ into ${PREFIX}
+ dobin bin/*
+ insinto ${PREFIX}
+ doins -r etc include lib* share
+ insinto ${PREFIX}/share/gps/plug-ins
+ doins share/examples/gnat/gnat-examples.xml
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/cc1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/cc1plus || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/collect2 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/gnat1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/liblto_plugin.so.0.0.0 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/lto1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/lto-wrapper || die
+ fperms 755 ${PREFIX}/libexec/gprbuild/gprbind || die
+ fperms 755 ${PREFIX}/libexec/gprbuild/gprlib || die
+}
+
+pkg_postinst () {
+ einfo "GNAT GPL is now installed. To launch it, you must put"
+ einfo " ${PREFIX}/bin"
+ einfo "in front of your PATH environment variable. The following"
+ einfo "commands enable you to do this:"
+ einfo " PATH=${PREFIX}/bin:\$PATH; export PATH (Bourne shell)"
+ einfo " setenv PATH ${PREFIX}/bin:\$PATH (C shell)"
+ einfo " Thank you for installing GNAT GPL Edition"
+}
diff --git a/dev-ada/gnat-suite-bin/gnat-suite-bin-2017.ebuild b/dev-ada/gnat-suite-bin/gnat-suite-bin-2017.ebuild
new file mode 100644
index 000000000000..a37e17c0d991
--- /dev/null
+++ b/dev-ada/gnat-suite-bin/gnat-suite-bin-2017.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MYP=gnat-gpl-${PV}
+DESCRIPTION="GNAT Ada suite"
+HOMEPAGE="http://libre.adacore.com/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/591c6d80c7a447af2deed1d7
+ -> ${MYP}-x86_64-linux-bin.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-devel/binutils
+ sys-devel/gdb"
+
+S="${WORKDIR}"/${MYP}-x86_64-linux-bin
+
+PREFIX=/opt/${P}
+
+src_prepare() {
+ default
+ rm Makefile
+ cd share/examples/gnat
+ cat header.xml \
+ full_project/full.xml \
+ options/options.xml \
+ other_languages/cpp_main/cpp_main.xml \
+ other_languages/cpp_pragmas/cpp_pragmas.xml \
+ other_languages/import_from_c/import_from_c.xml \
+ plugins/plugins.xml \
+ stream_io/stream_io.xml \
+ simple_project/simple_project.xml \
+ starter/starter.xml \
+ xml_stream/xml_stream.xml \
+ containers/anagram/anagram.xml \
+ containers/genealogy/genealogy.xml \
+ containers/hash/hash.xml \
+ containers/library/library.xml \
+ containers/shapes/shapes.xml \
+ containers/spellcheck/spellcheck.xml \
+ containers/wordcount/wordcount.xml \
+ containers/wordfreq/wordfreq.xml \
+ oo_interfaces/oo_interfaces.xml \
+ oo_airline/oo_airline.xml \
+ altivec/altivec.xml \
+ footer.xml \
+ > gnat-examples.xml \
+ || die
+ sed -i \
+ -e "s:PREFIX:${PREFIX}:" \
+ gnat-examples.xml || die
+ cd ../../..
+
+ # Remove objects from binutils
+ cd bin
+ rm addr2line ar c++filt gprof ld.* nm obj* r* s* || die
+ cd ..
+ rm share/doc/gnat/info/{as,bfd,binutils,ld}.info || die
+
+ # Remove objects from gdb
+ cd bin
+ rm gdb gdbserver gcore || die
+ cd ..
+ rm -r include/gdb || die
+ rm lib*/libinproctrace.so || die
+ rm -r share/gdb-* || die
+ rm share/doc/gnat/info/gdb.info || die
+
+ basever=6.3.1
+ machine=x86_64-pc-linux-gnu
+ rm libexec//gcc/${machine}/${basever}/ld || die
+}
+
+src_install() {
+ into ${PREFIX}
+ dobin bin/*
+ insinto ${PREFIX}
+ doins -r etc include lib* share
+ insinto ${PREFIX}/share/gps/plug-ins
+ doins share/examples/gnat/gnat-examples.xml
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/cc1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/cc1plus || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/collect2 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/gnat1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/liblto_plugin.so.0.0.0 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/lto1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/lto-wrapper || die
+ fperms 755 ${PREFIX}/libexec/gprbuild/gprbind || die
+ fperms 755 ${PREFIX}/libexec/gprbuild/gprlib || die
+}
+
+pkg_postinst () {
+ einfo "GNAT GPL is now installed. To launch it, you must put"
+ einfo " ${PREFIX}/bin"
+ einfo "in front of your PATH environment variable. The following"
+ einfo "commands enable you to do this:"
+ einfo " PATH=${PREFIX}/bin:\$PATH; export PATH (Bourne shell)"
+ einfo " setenv PATH ${PREFIX}/bin:\$PATH (C shell)"
+ einfo " Thank you for installing GNAT GPL Edition"
+}
diff --git a/dev-ada/gnat-suite-bin/gnat-suite-bin-2018.ebuild b/dev-ada/gnat-suite-bin/gnat-suite-bin-2018.ebuild
new file mode 100644
index 000000000000..c7773b2d48d2
--- /dev/null
+++ b/dev-ada/gnat-suite-bin/gnat-suite-bin-2018.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MYP=gnat-gpl-${PV}
+DESCRIPTION="GNAT Ada suite"
+HOMEPAGE="http://libre.adacore.com/"
+# Extracted and repacked from http://mirrors.cdn.adacore.com/art/5b0d7bffa3f5d709751e3e04
+SRC_URI="https://dev.gentoo.org/~tupone/distfiles/${P}.txz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-devel/binutils
+ sys-devel/gdb"
+
+PREFIX=/opt/${P}
+
+src_prepare() {
+ default
+ rm Makefile
+ cd share/examples/gnat
+ cat header.xml \
+ full_project/full.xml \
+ options/options.xml \
+ other_languages/cpp_main/cpp_main.xml \
+ other_languages/cpp_pragmas/cpp_pragmas.xml \
+ other_languages/import_from_c/import_from_c.xml \
+ plugins/plugins.xml \
+ stream_io/stream_io.xml \
+ simple_project/simple_project.xml \
+ starter/starter.xml \
+ xml_stream/xml_stream.xml \
+ containers/anagram/anagram.xml \
+ containers/genealogy/genealogy.xml \
+ containers/hash/hash.xml \
+ containers/library/library.xml \
+ containers/shapes/shapes.xml \
+ containers/spellcheck/spellcheck.xml \
+ containers/wordcount/wordcount.xml \
+ containers/wordfreq/wordfreq.xml \
+ oo_interfaces/oo_interfaces.xml \
+ oo_airline/oo_airline.xml \
+ altivec/altivec.xml \
+ footer.xml \
+ > gnat-examples.xml \
+ || die
+ sed -i \
+ -e "s:PREFIX:${PREFIX}:" \
+ gnat-examples.xml || die
+}
+
+src_install() {
+ into ${PREFIX}
+ dobin bin/*
+ insinto ${PREFIX}
+ doins -r etc include lib* share
+ insinto ${PREFIX}/share/gps/plug-ins
+ doins share/examples/gnat/gnat-examples.xml
+ basever=7.3.1
+ machine=x86_64-pc-linux-gnu
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/cc1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/cc1plus || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/collect2 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/gnat1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/liblto_plugin.so.0.0.0 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/lto1 || die
+ fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/lto-wrapper || die
+ fperms 755 ${PREFIX}/libexec/gprbuild/gprbind || die
+ fperms 755 ${PREFIX}/libexec/gprbuild/gprlib || die
+}
+
+pkg_postinst () {
+ einfo "GNAT GPL is now installed. To launch it, you must put"
+ einfo " ${PREFIX}/bin"
+ einfo "in front of your PATH environment variable. The following"
+ einfo "commands enable you to do this:"
+ einfo " PATH=${PREFIX}/bin:\$PATH; export PATH (Bourne shell)"
+ einfo " setenv PATH ${PREFIX}/bin:\$PATH (C shell)"
+ einfo " Thank you for installing GNAT GPL Edition"
+}
diff --git a/dev-ada/gnat-suite-bin/metadata.xml b/dev-ada/gnat-suite-bin/metadata.xml
new file mode 100644
index 000000000000..1fbf6928a092
--- /dev/null
+++ b/dev-ada/gnat-suite-bin/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ada@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ GNAT Community Edition: Ada Compiler and Gnat Programming System delivered as binaries
+ </longdescription>
+</pkgmetadata>