summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-03 15:49:06 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-03 15:49:06 +0100
commit128c4b0b6c73f994174bf351d311ed021adbc6f7 (patch)
treeb29ea0b846a53af1bc54ded701368dd2ff5f638a /dev-cpp/muParser
parentwww-apps/prowlarr: drop 1.0.0.2171 (diff)
downloadgentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.tar.gz
gentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.tar.bz2
gentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.zip
*/*: make mycmakeargs local
Closes: https://github.com/gentoo/gentoo/pull/28947 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp/muParser')
-rw-r--r--dev-cpp/muParser/muParser-2.3.2-r1.ebuild4
-rw-r--r--dev-cpp/muParser/muParser-2.3.3-r1.ebuild11
-rw-r--r--dev-cpp/muParser/muParser-2.3.3.ebuild7
-rw-r--r--dev-cpp/muParser/muParser-2.3.4.ebuild11
4 files changed, 8 insertions, 25 deletions
diff --git a/dev-cpp/muParser/muParser-2.3.2-r1.ebuild b/dev-cpp/muParser/muParser-2.3.2-r1.ebuild
index a7adf4aa3980..9023bc7bc987 100644
--- a/dev-cpp/muParser/muParser-2.3.2-r1.ebuild
+++ b/dev-cpp/muParser/muParser-2.3.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,7 +19,7 @@ RESTRICT="!test? ( test )"
PATCHES=( "${FILESDIR}/muParser-2.3-export-cmake.patch" )
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DENABLE_OPENMP=$(usex openmp)
)
cmake_src_configure
diff --git a/dev-cpp/muParser/muParser-2.3.3-r1.ebuild b/dev-cpp/muParser/muParser-2.3.3-r1.ebuild
index b5702ad96464..669ac8313f52 100644
--- a/dev-cpp/muParser/muParser-2.3.3-r1.ebuild
+++ b/dev-cpp/muParser/muParser-2.3.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,11 +21,8 @@ RESTRICT="!test? ( test )"
S="${S}${suffix}"
-PATCHES=(
-)
-
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DENABLE_OPENMP=$(usex openmp)
-DENABLE_WIDE_CHAR=$(usex wchar)
)
@@ -35,7 +32,3 @@ src_configure() {
src_test() {
cmake_src_compile test
}
-
-src_install() {
- cmake_src_install
-}
diff --git a/dev-cpp/muParser/muParser-2.3.3.ebuild b/dev-cpp/muParser/muParser-2.3.3.ebuild
index ab201cd8c983..fc2e66b58f60 100644
--- a/dev-cpp/muParser/muParser-2.3.3.ebuild
+++ b/dev-cpp/muParser/muParser-2.3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,11 +21,8 @@ RESTRICT="!test? ( test )"
S="${S}${suffix}"
-PATCHES=(
-)
-
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DENABLE_OPENMP=$(usex openmp)
)
cmake_src_configure
diff --git a/dev-cpp/muParser/muParser-2.3.4.ebuild b/dev-cpp/muParser/muParser-2.3.4.ebuild
index 4dd7dfcdf406..d085086ce7f7 100644
--- a/dev-cpp/muParser/muParser-2.3.4.ebuild
+++ b/dev-cpp/muParser/muParser-2.3.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,11 +16,8 @@ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-li
IUSE="doc openmp test wchar"
RESTRICT="!test? ( test )"
-PATCHES=(
-)
-
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DENABLE_OPENMP=$(usex openmp)
-DENABLE_WIDE_CHAR=$(usex wchar)
)
@@ -30,7 +27,3 @@ src_configure() {
src_test() {
cmake_src_compile test
}
-
-src_install() {
- cmake_src_install
-}