summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-01-22 20:06:16 -0600
committerMatthias Maier <tamiko@gentoo.org>2023-01-22 20:06:16 -0600
commitf191cdee2c217ad2a0af7f37459c438614650472 (patch)
treeb11d59593adb64ba20cd3ddc4fbc518f3d07d5e0 /dev-cpp/muParser
parentdev-cpp/muParser: drop 2.3.2-r1, 2.3.3 (diff)
downloadgentoo-f191cdee2c217ad2a0af7f37459c438614650472.tar.gz
gentoo-f191cdee2c217ad2a0af7f37459c438614650472.tar.bz2
gentoo-f191cdee2c217ad2a0af7f37459c438614650472.zip
dev-cpp/muParser: Remove USE=wchar
Unfortunately, this innocent looking USE flag incurs a silent ABI change that let's all its reverse dependencies fail. A number of the reverse dependencies of muParser already set muParser[-wchar] explicitly and the rest is probably also not compiling. Thus, remove the use flag. If someone wants to have wchar_t support in muParser then a proper solution would be to slot the package and install both ABI variants simultaneously. Closes: https://bugs.gentoo.org/880133 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-cpp/muParser')
-rw-r--r--dev-cpp/muParser/metadata.xml3
-rw-r--r--dev-cpp/muParser/muParser-2.3.3-r2.ebuild (renamed from dev-cpp/muParser/muParser-2.3.3-r1.ebuild)3
-rw-r--r--dev-cpp/muParser/muParser-2.3.4-r1.ebuild (renamed from dev-cpp/muParser/muParser-2.3.4.ebuild)3
3 files changed, 2 insertions, 7 deletions
diff --git a/dev-cpp/muParser/metadata.xml b/dev-cpp/muParser/metadata.xml
index 05a26448f3c7..c81547b2e58d 100644
--- a/dev-cpp/muParser/metadata.xml
+++ b/dev-cpp/muParser/metadata.xml
@@ -14,7 +14,4 @@
<remote-id type="sourceforge">muparser</remote-id>
<remote-id type="github">beltoforion/muparser</remote-id>
</upstream>
- <use>
- <flag name="wchar">Add support for wide character (wchar_t)</flag>
- </use>
</pkgmetadata>
diff --git a/dev-cpp/muParser/muParser-2.3.3-r1.ebuild b/dev-cpp/muParser/muParser-2.3.3-r2.ebuild
index 669ac8313f52..cab8c4f6caf3 100644
--- a/dev-cpp/muParser/muParser-2.3.3-r1.ebuild
+++ b/dev-cpp/muParser/muParser-2.3.3-r2.ebuild
@@ -16,7 +16,7 @@ S="${WORKDIR}"/muparser-${PV}
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~loong ~ppc ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc openmp test wchar"
+IUSE="doc openmp test"
RESTRICT="!test? ( test )"
S="${S}${suffix}"
@@ -24,7 +24,6 @@ S="${S}${suffix}"
src_configure() {
local mycmakeargs=(
-DENABLE_OPENMP=$(usex openmp)
- -DENABLE_WIDE_CHAR=$(usex wchar)
)
cmake_src_configure
}
diff --git a/dev-cpp/muParser/muParser-2.3.4.ebuild b/dev-cpp/muParser/muParser-2.3.4-r1.ebuild
index d085086ce7f7..363cf05aaf0d 100644
--- a/dev-cpp/muParser/muParser-2.3.4.ebuild
+++ b/dev-cpp/muParser/muParser-2.3.4-r1.ebuild
@@ -13,13 +13,12 @@ S="${WORKDIR}"/muparser-${PV}
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc openmp test wchar"
+IUSE="doc openmp test"
RESTRICT="!test? ( test )"
src_configure() {
local mycmakeargs=(
-DENABLE_OPENMP=$(usex openmp)
- -DENABLE_WIDE_CHAR=$(usex wchar)
)
cmake_src_configure
}