summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-16 22:28:33 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-16 22:55:54 +0100
commite8f313f0adb4ec7c200687504215541d53ef0049 (patch)
tree3a47f864f8450492c925e74323bb4e86b88bd656 /dev-cpp
parentdev-python/pyatspi: Drop old (diff)
downloadgentoo-e8f313f0adb4ec7c200687504215541d53ef0049.tar.gz
gentoo-e8f313f0adb4ec7c200687504215541d53ef0049.tar.bz2
gentoo-e8f313f0adb4ec7c200687504215541d53ef0049.zip
dev-cpp/cairomm: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cairomm/Manifest1
-rw-r--r--dev-cpp/cairomm/cairomm-1.12.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-cpp/cairomm/Manifest b/dev-cpp/cairomm/Manifest
index 6a829393b2c8..f416e08dd4a8 100644
--- a/dev-cpp/cairomm/Manifest
+++ b/dev-cpp/cairomm/Manifest
@@ -1 +1,2 @@
DIST cairomm-1.10.0.tar.gz 1089577 SHA256 068d96c43eae7b0a3d98648cbfc6fbd16acc385858e9ba6d37b5a47e4dba398f SHA512 974b1c078c8d7b82f8d026e384811c016fa95cb62942fc12717edd993cb1660bc004bee5f8ce31c0540ef8d4105a2d86cd461ed3f5e996fd3faf65dfb37ac9e2 WHIRLPOOL 4fdea4df681b340729b64241baa84bc2171e6d98e2d277f13c8e51cee121bf7d3adef85e3d189d6e549213694a08ee72dafb2744c63377599491addcf609b447
+DIST cairomm-1.12.0.tar.xz 789588 SHA256 a54ada8394a86182525c0762e6f50db6b9212a2109280d13ec6a0b29bfd1afe6 SHA512 750e05f079c2ee9786d1a1ddb66ff90405549a82aeb542d585f904f7147994a451950a77ecb563f290cf2358f7010360ab03d9aa3a319651615c48bd25aeb7e8 WHIRLPOOL 757c93d5a607b50452ee590a13907522615a032cc3b4b284f9bb465183b7edd0fe16ba4f528b7c49d3c17892e194d4719f6d22e78824e22cc0c2d9a6e80f66fb
diff --git a/dev-cpp/cairomm/cairomm-1.12.0.ebuild b/dev-cpp/cairomm/cairomm-1.12.0.ebuild
new file mode 100644
index 000000000000..2dc4fc7b5327
--- /dev/null
+++ b/dev-cpp/cairomm/cairomm-1.12.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ bindings for the Cairo vector graphics library"
+HOMEPAGE="http://cairographics.org/cairomm"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc +svg"
+
+# FIXME: svg support is automagic
+RDEPEND="
+ >=x11-libs/cairo-1.12.10[svg?,${MULTILIB_USEDEP}]
+ >=dev-libs/libsigc++-2.3.2:2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz )
+"
+
+src_prepare() {
+ # don't waste time building examples because they are marked as "noinst"
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || die
+
+ # don't waste time building tests
+ # they require the boost Unit Testing framework, that's not in base boost
+ sed -i 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ --disable-tests \
+ $(multilib_native_use_enable doc documentation)
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}