summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-19 12:04:04 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-19 12:09:46 +0100
commitfa972fb39666a828fa1468fd15431f263cde29e1 (patch)
tree04936837a672c21ad83388f87e978c381114e96c /dev-cpp
parentmedia-sound/pavucontrol: Fix building with latest glibmm/libsigc++ (#567216) (diff)
downloadgentoo-fa972fb39666a828fa1468fd15431f263cde29e1.tar.gz
gentoo-fa972fb39666a828fa1468fd15431f263cde29e1.tar.bz2
gentoo-fa972fb39666a828fa1468fd15431f263cde29e1.zip
dev-cpp/gconfmm: Fix building with latest glibmm/libsigc++ (#568580)
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gconfmm/Manifest1
-rw-r--r--dev-cpp/gconfmm/gconfmm-2.28.3-r1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-cpp/gconfmm/Manifest b/dev-cpp/gconfmm/Manifest
index d4e406edca94..dc7152e74acd 100644
--- a/dev-cpp/gconfmm/Manifest
+++ b/dev-cpp/gconfmm/Manifest
@@ -1 +1,2 @@
+DIST gconfmm-2.28.3.tar.bz2 471125 SHA256 a5e0092bb73371a3ca76b2ecae794778f3a9409056fee9b28ec1db072d8e6108 SHA512 0fd3a43373dfdf514eca61537c19dafd4ad582d2ec6bb325652766fba90ed723feff6daf93effcdf20f917c573131d58c16f1a826194f653864a701bb8a57097 WHIRLPOOL 361aeef2173cbc0f43efacf8b612f1a933e332e94f1b57d1039a67e08bd3757524b6d68347c136f650523b1a80e97267c60babed6e0caa158c8452be8c39db32
DIST gconfmm-2.28.3.tar.xz 376840 SHA256 d7bd2d29c1a87b85329547fb29a0eca52d944e60699982152775002e24c09228 SHA512 8a6f34b175fd2370d596ef859b7075140441f14b97b708afd96bae25874780d321ed81905182ed50abaf6f41f710a325b8053b9aef511cd242df43570646df73 WHIRLPOOL 452f600bb03670a09797ac43c547e7038c16f322f372dd1a4db9ec4a5646ecb4be40a69e2aa91aaa849a3211268d060bcca4b44a438c8c194261253d71d89bc5
diff --git a/dev-cpp/gconfmm/gconfmm-2.28.3-r1.ebuild b/dev-cpp/gconfmm/gconfmm-2.28.3-r1.ebuild
new file mode 100644
index 000000000000..b490b1a48a30
--- /dev/null
+++ b/dev-cpp/gconfmm/gconfmm-2.28.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit flag-o-matic gnome2
+
+DESCRIPTION="C++ bindings for GConf"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="
+ >=gnome-base/gconf-2.4:2
+ >=dev-cpp/glibmm-2.12:2[doc?]
+ >=dev-cpp/gtkmm-2.4:2.4
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ append-cxxflags -std=c++11 #568580
+ gnome2_src_configure \
+ $(use_enable doc documentation)
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ dohtml -r docs/reference/html/*
+ fi
+}