summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/picp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/picp')
-rw-r--r--dev-embedded/picp/Manifest1
-rw-r--r--dev-embedded/picp/files/picp-0.6.8-errno.patch10
-rw-r--r--dev-embedded/picp/metadata.xml5
-rw-r--r--dev-embedded/picp/picp-0.6.8.ebuild42
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-embedded/picp/Manifest b/dev-embedded/picp/Manifest
new file mode 100644
index 000000000000..35b78ebf7791
--- /dev/null
+++ b/dev-embedded/picp/Manifest
@@ -0,0 +1 @@
+DIST picp-0.6.8.tar.gz 125303 SHA256 869c680ff8137257d635e8ab8fdaacef21175bf98b930cc6aaaa2f935b06c5b6 SHA512 03b8f55f3ae69d87dc02a2df6cad718c3d9fec725eae469b9e28e411620c95e7c1f2d241110cb6a5561e8d9727da3319e2b7caaeefa7a68239009317c8df9471 WHIRLPOOL d7de7a089e3cfa83419669befe53835e307997b8cd78cd3cf76729f47d69d154d26dab6daf90a3f10cbe785cfe9b5b6348f3e166b7c0f05a103dbf36405387bd
diff --git a/dev-embedded/picp/files/picp-0.6.8-errno.patch b/dev-embedded/picp/files/picp-0.6.8-errno.patch
new file mode 100644
index 000000000000..89d5d063576d
--- /dev/null
+++ b/dev-embedded/picp/files/picp-0.6.8-errno.patch
@@ -0,0 +1,10 @@
+--- picp-0.6.8/picsnoop/picsnoop.c.orig
++++ picp-0.6.8/picsnoop/picsnoop.c
+@@ -40,6 +40,7 @@
+ #include <string.h>
+ #include <unistd.h>
+ #include <signal.h>
++#include <errno.h>
+ #include <ctype.h>
+
+ #ifdef WIN32
diff --git a/dev-embedded/picp/metadata.xml b/dev-embedded/picp/metadata.xml
new file mode 100644
index 000000000000..92114080841c
--- /dev/null
+++ b/dev-embedded/picp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+</pkgmetadata>
diff --git a/dev-embedded/picp/picp-0.6.8.ebuild b/dev-embedded/picp/picp-0.6.8.ebuild
new file mode 100644
index 000000000000..7233accdc283
--- /dev/null
+++ b/dev-embedded/picp/picp-0.6.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A commandline interface to Microchip's PICSTART+ programmer"
+HOMEPAGE="http://home.pacbell.net/theposts/picmicro/"
+SRC_URI="http://home.pacbell.net/theposts/picmicro/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+src_prepare() {
+ sed -i -e '/strip/d' \
+ -e 's:$(CC):\0 $(LDFLAGS):' \
+ {.,fixchksum,picsnoop}/Makefile || die "sed failed"
+
+ rm -f picsnoop/{picsnoop,*.o}
+
+ epatch "${FILESDIR}"/${P}-errno.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) OPTIONS="${CFLAGS} -x c++"
+ emake -C picsnoop CC=$(tc-getCC) OPTIONS="${CFLAGS} -x c++"
+ emake -C fixchksum CC=$(tc-getCC) OPTIONS="${CFLAGS}"
+}
+
+src_install() {
+ dobin picp
+ dobin picsnoop/picsnoop
+ dobin fixchksum/fixchksum
+ dodoc README HISTORY LICENSE.TXT NOTES PSCOMMANDS.TXT BugReports.txt TODO
+ newdoc picsnoop/README.TXT PICSNOOP.txt
+ newdoc fixchksum/README fixchksum.txt
+ dohtml PICPmanual.html
+}