summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2015-08-26 10:46:15 -0700
committerZac Medico <zmedico@gentoo.org>2015-08-26 10:46:34 -0700
commit836fd3187a478452effc14bd3db092c8cf7d3345 (patch)
treef8a95156c7c9ac02ffd22bfb628279e7483f0aea /dev-go
parentprofiles: delete an obsolete p.use.mask entry for PyQt4 (diff)
downloadgentoo-836fd3187a478452effc14bd3db092c8cf7d3345.tar.gz
gentoo-836fd3187a478452effc14bd3db092c8cf7d3345.tar.bz2
gentoo-836fd3187a478452effc14bd3db092c8cf7d3345.zip
dev-go/go-tools: revbump to 0_pre20150823-r1, fixing file collisions for bug 558818
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-tools/go-tools-0_pre20150823-r1.ebuild (renamed from dev-go/go-tools/go-tools-0_pre20150823.ebuild)7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-go/go-tools/go-tools-0_pre20150823.ebuild b/dev-go/go-tools/go-tools-0_pre20150823-r1.ebuild
index ac8982ed2b2e..887effab69f0 100644
--- a/dev-go/go-tools/go-tools-0_pre20150823.ebuild
+++ b/dev-go/go-tools/go-tools-0_pre20150823-r1.ebuild
@@ -81,7 +81,12 @@ src_install() {
cp -sR "$(go env GOROOT)" "${T}/goroot" || die
GOROOT="${T}/goroot" golang-build_src_install
- dobin bin/* "${T}/goroot/bin/godoc"
+
+ # bug 558818: install binaries in $GOROOT/bin to avoid file collisions
+ exeinto "$(go env GOROOT)/bin"
+ doexe bin/* "${T}/goroot/bin/godoc"
+ dodir /usr/bin
+ ln "${ED}$(go env GOROOT)/bin/godoc" "${ED}usr/bin/godoc" || die
if has_version '<dev-lang/go-1.5'; then
exeinto "$(go env GOTOOLDIR)"