summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-17 14:07:01 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-17 19:00:52 -0500
commitfad5225ceabfb97464df13681b26da01fd32d123 (patch)
tree6bd07fab0534c90bda891a89b0ee7ff9467e6c27 /dev-java/jopt-simple/jopt-simple-4.6.ebuild
parentgames-rpg/xu4: remove deprecated games eclass (diff)
downloadgentoo-fad5225ceabfb97464df13681b26da01fd32d123.tar.gz
gentoo-fad5225ceabfb97464df13681b26da01fd32d123.tar.bz2
gentoo-fad5225ceabfb97464df13681b26da01fd32d123.zip
dev-java/jopt-simple: add 4.6
Unfortuantely this is needed by jmh, whose upstream is using it, and does not seem open to the idea of migrating forward. Upstream bug: http://mail.openjdk.java.net/pipermail/jmh-dev/2016-October/002395.html Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-java/jopt-simple/jopt-simple-4.6.ebuild')
-rw-r--r--dev-java/jopt-simple/jopt-simple-4.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/jopt-simple/jopt-simple-4.6.ebuild b/dev-java/jopt-simple/jopt-simple-4.6.ebuild
new file mode 100644
index 000000000000..bf49832e58f2
--- /dev/null
+++ b/dev-java/jopt-simple/jopt-simple-4.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A Java library for parsing command line options"
+HOMEPAGE="https://pholser.github.com/jopt-simple/"
+SRC_URI="https://github.com/pholser/${PN}/tarball/${P} -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6"
+
+S="${WORKDIR}/pholser-jopt-simple-8808a39"
+
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ # Easier to use java-pkg-simple.
+ rm -v pom.xml || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc README.md
+}