summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jsr173/jsr173-1.0-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jsr173/jsr173-1.0-r1.ebuild')
-rw-r--r--dev-java/jsr173/jsr173-1.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-java/jsr173/jsr173-1.0-r1.ebuild b/dev-java/jsr173/jsr173-1.0-r1.ebuild
new file mode 100644
index 000000000000..75fdc3b5237e
--- /dev/null
+++ b/dev-java/jsr173/jsr173-1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The Streaming API for XML (StAX) is a Java API for parsing and writing XML easily and efficiently"
+HOMEPAGE="http://dev2dev.bea.com/xml/stax.html"
+SRC_URI="http://ftpna2.bea.com/pub/downloads/${PN}.jar"
+
+LICENSE="bea.ri.jsr173"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.3
+ dev-java/jaxme"
+DEPEND=">=virtual/jdk-1.3
+ ${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cd "${S}"
+ jar xvf ${DISTDIR}/${A} || die "failed to unpack"
+
+ cp "${FILESDIR}/build-${PVR}.xml" build.xml
+
+ jar xvf ${P//-/_}_src.jar || die "failed to unpack"
+ rm -v *.jar || die
+ cd lib
+ rm -v *.jar || die
+ java-pkg_jarfrom jaxme
+}
+
+src_compile() {
+ local antflags="-Dproject.name=${PN} jar"
+ eant ${antflags} $(use_doc) || die "Compilation failed"
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ use doc && java-pkg_dojavadoc dist/doc/api
+ use source && java-pkg_dosrc src/*
+}