summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/swarmcache
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/swarmcache')
-rw-r--r--dev-java/swarmcache/Manifest1
-rw-r--r--dev-java/swarmcache/metadata.xml5
-rw-r--r--dev-java/swarmcache/swarmcache-1.0_pre20050106-r1.ebuild49
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-java/swarmcache/Manifest b/dev-java/swarmcache/Manifest
new file mode 100644
index 000000000000..8a928e3325c5
--- /dev/null
+++ b/dev-java/swarmcache/Manifest
@@ -0,0 +1 @@
+DIST swarmcache-1.0_pre20050106.tar.bz2 34632 SHA256 9d34c3b20c9b227661e2aaecd4aba11bacd46d9f885cdf116cd340966081e382 SHA512 21c05d83a6e05f3c31a1785e0286d2f584375e3aa97e9fa2dd18a0aca5f3678817a6a019524e6b55c2f047547296cec83c9e108c9272401b592ea0f8338878d7 WHIRLPOOL fb30a849e0e6d894b5300a8feb9bc9a5da6792fbc72b3029407621abaf09a09ea164dba4d2d2b2932437c37322c2f66362a155b59394970c8f0dc33c642d127f
diff --git a/dev-java/swarmcache/metadata.xml b/dev-java/swarmcache/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/swarmcache/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/swarmcache/swarmcache-1.0_pre20050106-r1.ebuild b/dev-java/swarmcache/swarmcache-1.0_pre20050106-r1.ebuild
new file mode 100644
index 000000000000..4bc905db42d2
--- /dev/null
+++ b/dev-java/swarmcache/swarmcache-1.0_pre20050106-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="SwarmCache is a simple but effective distributed cache"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+HOMEPAGE="http://swarmcache.sourceforge.net"
+LICENSE="LGPL-2"
+SLOT="1.0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+COMMON_DEP=">=dev-java/commons-collections-3
+ >=dev-java/commons-logging-1.0.4
+ >=dev-java/jgroups-2.2.7"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}
+ >=dev-java/ant-core-1.5"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}/lib"
+ java-pkg_jar-from commons-collections
+ java-pkg_jar-from commons-logging
+ java-pkg_jar-from jgroups
+}
+
+#Tests seem to start a server that just waits
+#src_test() {
+# eant test
+#}
+RESTRICT="test"
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ dodoc *.txt
+ use doc && java-pkg_dojavadoc web/api
+ use source && java-pkg_dosrc src/net
+}