summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /dev-lang/parrot/parrot-7.11.0-r1.ebuild
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang/parrot/parrot-7.11.0-r1.ebuild')
-rw-r--r--dev-lang/parrot/parrot-7.11.0-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-lang/parrot/parrot-7.11.0-r1.ebuild b/dev-lang/parrot/parrot-7.11.0-r1.ebuild
index ecedd1c6ff5f..fe5c23fecbf8 100644
--- a/dev-lang/parrot/parrot-7.11.0-r1.ebuild
+++ b/dev-lang/parrot/parrot-7.11.0-r1.ebuild
@@ -55,27 +55,27 @@ src_configure() {
src_compile() {
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
# occasionally dies in parallel make
- emake -j1 || die
+ emake -j1
if use doc ; then
- emake -j1 html || die
+ emake -j1 html
fi
}
src_test() {
- emake -j1 test || die
+ emake -j1 test
}
src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- dosym parrot-ops2c /usr/bin/ops2c || die
+ emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
+ dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO
+ dosym parrot-ops2c /usr/bin/ops2c
if use examples; then
insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
+ doins -r examples/*
fi
if use doc; then
insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
+ doins -r editor
cd docs/html
dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
pmc.html tools.html docs src tools || die