summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/389-adminutil
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/389-adminutil')
-rw-r--r--dev-libs/389-adminutil/389-adminutil-1.1.15.ebuild47
-rw-r--r--dev-libs/389-adminutil/Manifest1
-rw-r--r--dev-libs/389-adminutil/metadata.xml7
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/389-adminutil/389-adminutil-1.1.15.ebuild b/dev-libs/389-adminutil/389-adminutil-1.1.15.ebuild
new file mode 100644
index 000000000000..e6481948bf2b
--- /dev/null
+++ b/dev-libs/389-adminutil/389-adminutil-1.1.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit libtool eutils
+
+MY_PV=${PV/_rc/.rc}
+MY_PV=${MY_PV/_a/.a}
+MY_P=${P/_rc/.rc}
+MY_P=${MY_P/_a/.a}
+
+DESCRIPTION="389 adminutil"
+HOMEPAGE="http://port389.org/"
+SRC_URI="http://port389.org/sources/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/nss-3.11.4
+ >=dev-libs/nspr-4.6.4
+ >=dev-libs/svrcore-4.0.3
+ >=dev-libs/cyrus-sasl-2.1.19
+ >=dev-libs/icu-3.4:=
+ net-nds/openldap"
+DEPEND="virtual/pkgconfig ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ --with-fhs \
+ --with-openldap \
+ --disable-rpath \
+ --disable-tests ||die "econf failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake failed"
+ dodoc README NEWS
+}
diff --git a/dev-libs/389-adminutil/Manifest b/dev-libs/389-adminutil/Manifest
new file mode 100644
index 000000000000..65a32469cb1d
--- /dev/null
+++ b/dev-libs/389-adminutil/Manifest
@@ -0,0 +1 @@
+DIST 389-adminutil-1.1.15.tar.bz2 283825 SHA256 8ca29db779c87f3c8c41ba793864454b094f41b5cdbf74b9b45967a81eb17958 SHA512 5ed8d758ee47a2e276bab73696067dd2acd36f15ea5b93b32e3e244530920d74d95a4a4ff96cd325f22ae4ce2cc764fef03c90497c0181cbc1f0291f260d8ddf WHIRLPOOL e68fd5975a2d871e0e2c79580ecc24f48091fc1418ec04816e39799ac17b2495fd3b25c26e7e55626da46210909a8e9ffc1c8d6ad140e3fce0f3665dff0de903
diff --git a/dev-libs/389-adminutil/metadata.xml b/dev-libs/389-adminutil/metadata.xml
new file mode 100644
index 000000000000..a40624fba8f0
--- /dev/null
+++ b/dev-libs/389-adminutil/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>