summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-24 16:25:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-24 16:25:00 +0200
commit92a7f8e62a40540d70d539a874b45604bce084e1 (patch)
tree9613ec5fc076e68bbaa4c5f40fefaa6f0961034b /dev-libs/c-capnproto
parentmedia-video/x264-encoder: bump a new snapshot (diff)
downloadgentoo-92a7f8e62a40540d70d539a874b45604bce084e1.tar.gz
gentoo-92a7f8e62a40540d70d539a874b45604bce084e1.tar.bz2
gentoo-92a7f8e62a40540d70d539a874b45604bce084e1.zip
dev-libs/c-capnproto: initial import; ebuild by me
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-libs/c-capnproto')
-rw-r--r--dev-libs/c-capnproto/Manifest1
-rw-r--r--dev-libs/c-capnproto/c-capnproto-0.1.ebuild25
-rw-r--r--dev-libs/c-capnproto/files/gtest.patch41
-rw-r--r--dev-libs/c-capnproto/metadata.xml8
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-libs/c-capnproto/Manifest b/dev-libs/c-capnproto/Manifest
new file mode 100644
index 000000000000..262db73365c3
--- /dev/null
+++ b/dev-libs/c-capnproto/Manifest
@@ -0,0 +1 @@
+DIST c-capnproto-0.1.tar.gz 64051 SHA256 34718b5e56972f3964b69fcc5eea254cfd76d133a1ccf63f84c9e5a5a0faeab9 SHA512 6d8c66061419edafa0e01220a4c0fd23feac1674bb73b6f34c0677edaef9118a87badcbf939390842caa6fa4eb9ed0bc9c8ff542641b563bf729339bff9df9bd WHIRLPOOL d4e6ce299c063dcc57a48afc4f4dcf5ea7fcb485d8e325be31ed37595cfd539a29532f59adb679d3185c1a5af281331a62d83567e9862af44d463784319d7135
diff --git a/dev-libs/c-capnproto/c-capnproto-0.1.ebuild b/dev-libs/c-capnproto/c-capnproto-0.1.ebuild
new file mode 100644
index 000000000000..23e6bcb674ef
--- /dev/null
+++ b/dev-libs/c-capnproto/c-capnproto-0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-utils
+
+DESCRIPTION="C library/compiler for the Cap'n Proto serialization/RPC protocol"
+HOMEPAGE="https://github.com/opensourcerouting/c-capnproto"
+SRC_URI="https://github.com/opensourcerouting/c-capnproto/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${DEPEND}
+ test? ( dev-cpp/gtest )"
+S="${WORKDIR}/${PN}-${P}"
+PATCHES=(
+ "${FILESDIR}/gtest.patch"
+)
diff --git a/dev-libs/c-capnproto/files/gtest.patch b/dev-libs/c-capnproto/files/gtest.patch
new file mode 100644
index 000000000000..b094c5e6f219
--- /dev/null
+++ b/dev-libs/c-capnproto/files/gtest.patch
@@ -0,0 +1,41 @@
+Index: c-capnproto-c-capnproto-0.1/configure.ac
+===================================================================
+--- c-capnproto-c-capnproto-0.1.orig/configure.ac
++++ c-capnproto-c-capnproto-0.1/configure.ac
+@@ -35,8 +35,6 @@ AC_SUBST(WERROR)
+ # AC_MSG_ERROR([capnproto base package (0.5.2 or newer) not found])
+ #])
+
+-AC_CONFIG_SUBDIRS([gtest/googletest])
+-
+ AC_CONFIG_FILES([
+ Makefile
+ c-capnproto.pc
+Index: c-capnproto-c-capnproto-0.1/Makefile.am
+===================================================================
+--- c-capnproto-c-capnproto-0.1.orig/Makefile.am
++++ c-capnproto-c-capnproto-0.1/Makefile.am
+@@ -41,12 +41,6 @@ noinst_HEADERS += \
+ compiler/c++.capnp.h \
+ compiler/test.capnp.h
+
+-GTEST_LDADD = gtest/googletest/lib/libgtest.la
+-gtest/googletest/lib/libgtest.la:
+- make -C gtest/googletest lib/libgtest.la
+-GTEST_CPPFLAGS = -I${srcdir}/gtest/googletest/include
+-DIST_SUBDIRS = gtest/googletest
+-
+ check_PROGRAMS += \
+ capn-test
+ capn_test_SOURCES = \
+@@ -55,8 +49,8 @@ capn_test_SOURCES = \
+ compiler/test.capnp.c \
+ compiler/schema-test.cpp \
+ compiler/schema.capnp.c
+-capn_test_CPPFLAGS = $(AM_CPPFLAGS) $(GTEST_CPPFLAGS)
++capn_test_CPPFLAGS = $(AM_CPPFLAGS)
+ capn_test_CXXFLAGS = -std=gnu++11 -pthread
+-capn_test_LDADD = libcapnp_c.la $(GTEST_LDADD)
++capn_test_LDADD = libcapnp_c.la -lgtest
+ capn_test_LDFLAGS = -pthread
+ TESTS = capn-test
diff --git a/dev-libs/c-capnproto/metadata.xml b/dev-libs/c-capnproto/metadata.xml
new file mode 100644
index 000000000000..7a70bde8ce0e
--- /dev/null
+++ b/dev-libs/c-capnproto/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+</pkgmetadata>