summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/ferrisloki
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/ferrisloki')
-rw-r--r--dev-libs/ferrisloki/Manifest1
-rw-r--r--dev-libs/ferrisloki/ferrisloki-3.0.13.ebuild44
-rw-r--r--dev-libs/ferrisloki/metadata.xml11
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/ferrisloki/Manifest b/dev-libs/ferrisloki/Manifest
new file mode 100644
index 000000000000..d698b3ee104c
--- /dev/null
+++ b/dev-libs/ferrisloki/Manifest
@@ -0,0 +1 @@
+DIST ferrisloki-3.0.13.tar.bz2 350509 SHA256 a39f8e93882e802563fa724cc1b392c31f25aec7c71beb0a60c20670b93be38a SHA512 1ccf8118c05babd8e4856dd40d60a1340d5db40b27aa8527343dabfeec74e8cbf99a713a19028f68e6a36369670a69f769b20a80f7aad27d2ccbbda32b393d40 WHIRLPOOL f4bdc97a177f45c092ce0f494c627c3a4016b4f2257479788fc8037f23f24b6cc388fa462a562c3c221427363593190cc4724dbd44d3f6679454135bddd941a3
diff --git a/dev-libs/ferrisloki/ferrisloki-3.0.13.ebuild b/dev-libs/ferrisloki/ferrisloki-3.0.13.ebuild
new file mode 100644
index 000000000000..837d8140f0c4
--- /dev/null
+++ b/dev-libs/ferrisloki/ferrisloki-3.0.13.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils multilib
+
+DESCRIPTION="Loki C++ library from Modern C++ Design"
+HOMEPAGE="http://www.libferris.com/"
+SRC_URI="mirror://sourceforge/witme/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs stlport"
+
+RDEPEND="stlport? ( >=dev-libs/STLport-5 )
+ dev-libs/libsigc++:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # derice this damn configure script
+ sed -i \
+ -e '/^CFLAGS/{s: -O3 : :g;s:-Wl,-O1 -Wl,--hash-style=both::;}' \
+ -e 's:-lstlport_gcc:-lstlport:' \
+ configure || die
+
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-stlport="${EPREFIX}/usr/include/stlport" \
+ $(use_enable stlport) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/ferrisloki/metadata.xml b/dev-libs/ferrisloki/metadata.xml
new file mode 100644
index 000000000000..0323b7006323
--- /dev/null
+++ b/dev-libs/ferrisloki/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cpp</herd>
+<use>
+ <flag name='stlport'>Include support for <pkg>dev-libs/STLport</pkg></flag>
+</use>
+<upstream>
+ <remote-id type="sourceforge">witme</remote-id>
+</upstream>
+</pkgmetadata>