summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/grok
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/grok')
-rw-r--r--dev-libs/grok/Manifest1
-rw-r--r--dev-libs/grok/files/0.9.2-Makefile.patch65
-rw-r--r--dev-libs/grok/grok-0.9.2.ebuild28
-rw-r--r--dev-libs/grok/metadata.xml11
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-libs/grok/Manifest b/dev-libs/grok/Manifest
new file mode 100644
index 000000000000..03070642cae1
--- /dev/null
+++ b/dev-libs/grok/Manifest
@@ -0,0 +1 @@
+DIST grok-0.9.2.tar.gz 243554 SHA256 40edbdba488ff9145832c7adb04b27630ca2617384fbef2af014d0e5a76ef636 SHA512 91d410259e89de6fbab011691cf56497158bc7a508194e6d17a2b32c8b70650be3b40c4792390589929b0f553a92b81cd3981e84ddcbe6a6ea80ab8fcdb38b2e WHIRLPOOL 90d0fb5418491435b57335792626d633edc50f348ba4a211a53f3c9acd46f5633b19b9d77642e787dd50e5feed57c2a5bbc78aeea1288c1b146a47e32c62317c
diff --git a/dev-libs/grok/files/0.9.2-Makefile.patch b/dev-libs/grok/files/0.9.2-Makefile.patch
new file mode 100644
index 000000000000..f10531646ad0
--- /dev/null
+++ b/dev-libs/grok/files/0.9.2-Makefile.patch
@@ -0,0 +1,65 @@
+diff --git a/grok-0.9.2/Makefile b/grok-0.9.2/Makefile
+index adfe869..fdced25 100644
+--- a/grok-0.9.2/Makefile
++++ b/grok-0.9.2/Makefile
+@@ -25,10 +25,12 @@ else
+ GPERF?=/usr/bin/gperf
+ endif
+
++LIBS=-lpcre -levent -rdynamic -ltokyocabinet
++
+ # For linux, we need libdl for dlopen()
+ # On FreeBSD, comment this line out.
+ ifeq ($(PLATFORM), GNULinux)
+-LDFLAGS+=-ldl
++LIBS+=-ldl
+ endif
+
+ # #############################################
+@@ -41,8 +43,7 @@ VERSION=$(shell sh $(BASE)/version.sh)
+ #CFLAGS+=-g
+ #LDFLAGS+=-g
+
+-CFLAGS+=-pipe -fPIC -I. -O2
+-LDFLAGS+=-lpcre -levent -rdynamic -ltokyocabinet
++CFLAGS+=-fPIC -I.
+
+ LIBSUFFIX=$(shell sh $(BASE)/platform.sh libsuffix)
+ VERLIBSUFFIX=$(shell sh $(BASE)/platform.sh libsuffix $(MAJOR))
+@@ -50,8 +51,8 @@ DYNLIBFLAG=$(shell sh $(BASE)/platform.sh dynlibflag)
+ LIBNAMEFLAG=$(shell sh $(BASE)/platform.sh libnameflag $(MAJOR) $(INSTALLLIB))
+
+ # Sane includes
+-CFLAGS+=-I/usr/local/include
+-LDFLAGS+=-L/usr/local/lib
++#CFLAGS+=-I/usr/local/include
++#LDFLAGS+=-L/usr/local/lib
+
+ # Platform so we know what to dlopen
+ CFLAGS+=-DPLATFORM_$(PLATFORM)
+@@ -97,6 +98,7 @@ install: libgrok.$(LIBSUFFIX) grok discogrok $(GROKHEADER)
+ install -m 755 grok $(DESTDIR)$(PREFIX)/bin
+ install -m 755 discogrok $(DESTDIR)$(PREFIX)/bin
+ install -m 644 libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/lib
++ ln -s libgrok.$(LIBSUFFIX) $(DESTDIR)$(PREFIX)/lib/libgrok.$(LIBSUFFIX).1
+ for header in $(GROKHEADER); do \
+ install -m 644 $$header $(DESTDIR)$(PREFIX)/include; \
+ done
+@@ -162,14 +164,14 @@ cleanver:
+ # Binary creation
+ grok: LDFLAGS+=-levent
+ grok: $(GROKOBJ) conf.tab.o conf.yy.o main.o grok_config.o
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
+
+ discogrok: $(GROKOBJ) discover_main.o
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
+
+ libgrok.$(LIBSUFFIX):
+ libgrok.$(LIBSUFFIX): $(GROKOBJ)
+- $(CC) $(LDFLAGS) -fPIC $(DYNLIBFLAG) $(LIBNAMEFLAG) $^ -o $@
++ $(CC) $(LDFLAGS) -fPIC $(DYNLIBFLAG) $(LIBNAMEFLAG) $^ $(LIBS) -o $@
+
+ libgrok.$(VERLIBSUFFIX): libgrok.$(LIBSUFFIX);
+ ln -s $< $@
diff --git a/dev-libs/grok/grok-0.9.2.ebuild b/dev-libs/grok/grok-0.9.2.ebuild
new file mode 100644
index 000000000000..b061208c02c4
--- /dev/null
+++ b/dev-libs/grok/grok-0.9.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="DRY and RAD for regular expressions"
+HOMEPAGE="https://github.com/jordansissel/grok http://code.google.com/p/semicomplete/wiki/Grok"
+SRC_URI="https://github.com/jordansissel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND="dev-db/tokyocabinet
+ >=dev-libs/libevent-1.3
+ >=dev-libs/libpcre-7.6"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-*.patch
+ tc-export CC
+}
diff --git a/dev-libs/grok/metadata.xml b/dev-libs/grok/metadata.xml
new file mode 100644
index 000000000000..26786e3c2888
--- /dev/null
+++ b/dev-libs/grok/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ercpe@gentoo.org</email>
+ <name>Johann Schmitz (ercpe)</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jordansissel/grok</remote-id>
+ </upstream>
+</pkgmetadata>