summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libburn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libburn')
-rw-r--r--dev-libs/libburn/Manifest2
-rw-r--r--dev-libs/libburn/libburn-1.3.8.ebuild43
-rw-r--r--dev-libs/libburn/libburn-1.4.0.ebuild43
-rw-r--r--dev-libs/libburn/metadata.xml18
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-libs/libburn/Manifest b/dev-libs/libburn/Manifest
new file mode 100644
index 000000000000..1e243e64bcd0
--- /dev/null
+++ b/dev-libs/libburn/Manifest
@@ -0,0 +1,2 @@
+DIST libburn-1.3.8.tar.gz 967404 SHA256 46266bdd4b37ca9700a44bbd8dbfbf3526423ede25751fd2f0211b2b5ce29283 SHA512 4f279319b49bc5f5d42751fcab16bfe949e14e6e1018f9138bcc9f8e10a298ecf9795780d5f8807c5c2bf1cc0332f931b709f1fb5809f30abb8054297370f3c6 WHIRLPOOL a814ab1c88b70b03788d490c1d6f9305878613d529fdd58df65a13bc683cf2e6c4e877192f85ffca07474a866115a34ef3932e838097e88db08d73554ed2ad3c
+DIST libburn-1.4.0.tar.gz 970395 SHA256 6c975abae4ae1f80e47fc5d1e235f85157f73e954c84627a5ef85d8b1b95ae94 SHA512 33c6eabe79343c9ebd198fb7c23900cac6b92b6834d80d2060062c48ca32a243566ebb3f86b51c5d149ef6aef4da2eaa340b3094960b0bce1fd67c0b82ee75f1 WHIRLPOOL 82f8186e9471a2046c627261da831250d0c60a9a1f8f6658a4238b2c35480b153a949189a5b89235449602919a33b81ff0c9fc728cef1757979e54080089a9d7
diff --git a/dev-libs/libburn/libburn-1.3.8.ebuild b/dev-libs/libburn/libburn-1.3.8.ebuild
new file mode 100644
index 000000000000..f6c8a8c7ab2b
--- /dev/null
+++ b/dev-libs/libburn/libburn-1.3.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Libburn is an open-source library for reading, mastering and writing optical discs"
+HOMEPAGE="http://libburnia-project.org"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="cdio debug static-libs track-src-odirect"
+
+RDEPEND="cdio? ( >=dev-libs/libcdio-0.83 )"
+DEPEND="$RDEPEND
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable track-src-odirect) \
+ --enable-pkg-check-modules \
+ $(use_enable cdio libcdio) \
+ --disable-ldconfig-at-install \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ dodoc CONTRIBUTORS doc/{comments,*.txt}
+
+ docinto cdrskin
+ dodoc cdrskin/{*.txt,README}
+ docinto cdrskin/html
+ dohtml cdrskin/cdrskin_eng.html
+
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libburn/libburn-1.4.0.ebuild b/dev-libs/libburn/libburn-1.4.0.ebuild
new file mode 100644
index 000000000000..bf3b79fa415e
--- /dev/null
+++ b/dev-libs/libburn/libburn-1.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Libburn is an open-source library for reading, mastering and writing optical discs"
+HOMEPAGE="http://libburnia-project.org"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cdio debug static-libs track-src-odirect"
+
+RDEPEND="cdio? ( >=dev-libs/libcdio-0.83 )"
+DEPEND="$RDEPEND
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable track-src-odirect) \
+ --enable-pkg-check-modules \
+ $(use_enable cdio libcdio) \
+ --disable-ldconfig-at-install \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ dodoc CONTRIBUTORS doc/{comments,*.txt}
+
+ docinto cdrskin
+ dodoc cdrskin/{*.txt,README}
+ docinto cdrskin/html
+ dohtml cdrskin/cdrskin_eng.html
+
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libburn/metadata.xml b/dev-libs/libburn/metadata.xml
new file mode 100644
index 000000000000..3bdc33646cf4
--- /dev/null
+++ b/dev-libs/libburn/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-optical</herd>
+<maintainer>
+<email>billie@gentoo.org</email>
+<name>Daniel Pielmeier</name>
+</maintainer>
+<longdescription lang="en">
+Libburn is an open-source library for reading, mastering and writing optical
+discs.
+</longdescription>
+<use>
+<flag name="track-src-odirect">Read track input with O_DIRECT (see man 2 open),
+this may deliver a better write performance in some situations</flag>
+<flag name="cdio">Enable EXPERIMENTAL use of libcdio as system adapter</flag>
+</use>
+</pkgmetadata>