summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2019-01-01 14:10:14 +0000
committerIan Whyman <thev00d00@gentoo.org>2019-01-01 14:10:33 +0000
commit967b252cdab700984444709e7c1f8f09983df58e (patch)
tree8c0078109a56a73d5de26bf14f330d1ba79e39b1 /dev-libs/libcec
parentnet-libs/courier-authlib: Raise courier-unicode dep to 2.1. (diff)
downloadgentoo-967b252cdab700984444709e7c1f8f09983df58e.tar.gz
gentoo-967b252cdab700984444709e7c1f8f09983df58e.tar.bz2
gentoo-967b252cdab700984444709e7c1f8f09983df58e.zip
dev-libs/libcec: Bump to 4.0.4
Closes: https://bugs.gentoo.org/673584 Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
Diffstat (limited to 'dev-libs/libcec')
-rw-r--r--dev-libs/libcec/Manifest1
-rw-r--r--dev-libs/libcec/libcec-4.0.4.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/libcec/Manifest b/dev-libs/libcec/Manifest
index 8f7754a6131a..046b38aebd6a 100644
--- a/dev-libs/libcec/Manifest
+++ b/dev-libs/libcec/Manifest
@@ -1,2 +1,3 @@
DIST libcec-3.1.0.tar.gz 1097121 BLAKE2B f216c03c26fd51366282d649d18ca969f362438a2803a7a15dc2aa1ec7caeb4e2a9f02b74e569da4d4c6aa24427ec5bd1870a230dc9c0bc575938c3929a7772b SHA512 e06f65d85ee268ec23380186d11e53f3e477bf25b955c9314cc13555eedeffee902dc8a0f3005248250c584760ab68c461b087b305dc4ef463da628ee1ab433b
DIST libcec-4.0.2.tar.gz 334995 BLAKE2B bdbebeb339ce39f2f740805c4c627cc5190cc0dd57d0d87e3d3aa4ba8feeba103336d035fb8b282358f2e08fa470111be43df4df48870be0e9aa93f35434d0ef SHA512 7bb80965cd1bef713f59bff136dc4a7f1172c4a9bdb8e2f59c6bcc5b74110848c0b2912263280ea68177908a688127e8d7208fc43ce6e65d589343b85395a0bb
+DIST libcec-4.0.4.tar.gz 344976 BLAKE2B ce88730ee6e9f57a3f874dd47343e8bb12bd9d3644b58703f0b797bfe656fa25461e6847db4023fec92d9e9740f0e58b59a203258d39d8883b8ae9cde147f455 SHA512 8991ba96fe9a87e5e1f63ff87f77fc0fc3b735c537e2ee6cb004fdc264d75cecd043e39b49cf9e64aeadd24bb1fb57911d9c4bd6c494d9ba4035d7320c268116
diff --git a/dev-libs/libcec/libcec-4.0.4.ebuild b/dev-libs/libcec/libcec-4.0.4.ebuild
new file mode 100644
index 000000000000..38c70e8e9200
--- /dev/null
+++ b/dev-libs/libcec/libcec-4.0.4.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+MY_PV=${PV/_p/-}
+MY_P=${PN}-${MY_PV}
+
+inherit cmake-utils linux-info python-single-r1 toolchain-funcs
+
+DESCRIPTION="Library for communicating with the Pulse-Eight USB HDMI-CEC Adaptor"
+HOMEPAGE="http://libcec.pulse-eight.com"
+SRC_URI="https://github.com/Pulse-Eight/${PN}/archive/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="cubox exynos python raspberry-pi +xrandr"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="virtual/udev
+ >=dev-libs/libplatform-2.0.0
+ sys-libs/ncurses:=
+ raspberry-pi? ( >=media-libs/raspberrypi-userland-0_pre20160305-r1 )
+ xrandr? ( x11-libs/libXrandr )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~USB_ACM"
+
+S="${WORKDIR}/${PN}-${MY_P}"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Do not hardcode the python libpath #577612
+ sed -i \
+ -e '/DESTINATION/s:lib/python${PYTHON_VERSION}/dist-packages:${PYTHON_SITEDIR}:' \
+ src/libcec/cmake/CheckPlatformSupport.cmake || die
+
+ use python || cmake_comment_add_subdirectory "src/pyCecClient"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSKIP_PYTHON_WRAPPER=$(usex !python)
+ -DHAVE_EXYNOS_API=$(usex exynos)
+ -DHAVE_TDA995X_API=$(usex cubox)
+ -DHAVE_RPI_API=$(usex raspberry-pi)
+ )
+ use python && mycmakeargs+=(
+ -DPYTHON_SITEDIR="$(python_get_sitedir)"
+ )
+
+ # raspberrypi-userland itself does not provide .pc file so using
+ # bcm_host.pc instead
+ use raspberry-pi && mycmakeargs+=(
+ -DRPI_INCLUDE_DIR=$( $(tc-getPKG_CONFIG) --variable=includedir bcm_host) \
+ -DRPI_LIB_DIR=$( $(tc-getPKG_CONFIG) --variable=libdir bcm_host)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "You will need to ensure the user running your CEC client has"
+ elog "read/write access to the device. You can ensure this by adding"
+ elog "them to the uucp group"
+}