summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libgusb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libgusb')
-rw-r--r--dev-libs/libgusb/Manifest2
-rw-r--r--dev-libs/libgusb/libgusb-0.2.4.ebuild53
-rw-r--r--dev-libs/libgusb/libgusb-0.2.5.ebuild52
-rw-r--r--dev-libs/libgusb/metadata.xml8
4 files changed, 115 insertions, 0 deletions
diff --git a/dev-libs/libgusb/Manifest b/dev-libs/libgusb/Manifest
new file mode 100644
index 000000000000..d932fd130425
--- /dev/null
+++ b/dev-libs/libgusb/Manifest
@@ -0,0 +1,2 @@
+DIST libgusb-0.2.4.tar.xz 273832 SHA256 437966fb45e30b8e757b2c200daf5d4e7dd22bf5aa80e151e3b1807270d38083 SHA512 51b51a613718507d5bcc5789c9583f48e31269cee6a673d1ebdfcca974c78b9395dddc9de0f09f925283798fa349e99b4e4ee4f7d67726235015d19c57f305c4 WHIRLPOOL 5e515aa4ad2a363067fdfe15507bb589e5200cdb505497bbe99d6440c05f853eea52ca776ea64743768d669e73a328a660f9cda894fbfdc1d4246de46b5b7fed
+DIST libgusb-0.2.5.tar.xz 275948 SHA256 a3ad56773548695292f49b62df1eb7fb1e87e1e0c9d3982e80f65f47095fa492 SHA512 6ac07c40faf6919991f5cbc3e5fd0523b7486b5437a6ac3d0bd1cfd05d645fe25e311366bb507d1b7af2fe913ae869523c052a7571cd8191914f8b1a81a4c22a WHIRLPOOL 3da2b781ef8df7912aababe174f83c020ac24fefc754303dd38beebd49fceaf40138cd601ffa11b02e2512e0e2ebe3727b1cdee89d0b504962d82a3898fd8c0f
diff --git a/dev-libs/libgusb/libgusb-0.2.4.ebuild b/dev-libs/libgusb/libgusb-0.2.4.ebuild
new file mode 100644
index 000000000000..2ac801ebe32a
--- /dev/null
+++ b/dev-libs/libgusb/libgusb-0.2.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 multilib-minimal vala
+
+DESCRIPTION="GObject wrapper for libusb"
+HOMEPAGE="https://gitorious.org/gusb/"
+SRC_URI="http://people.freedesktop.org/~hughsient/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86"
+
+IUSE="+introspection static-libs vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# Yes, we really need API from dev-libs/libusb-1.0.19, not virtual/libusb
+RDEPEND="
+ >=dev-libs/glib-2.28:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libusb-1.0.19[udev,${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.29 )
+"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-libs/libxslt
+ dev-util/gtk-doc-am
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ vala? ( $(vala_depend) )
+"
+
+# Tests try to access usb devices in /dev
+RESTRICT="test"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_enable vala)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/api/html docs/api/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/dev-libs/libgusb/libgusb-0.2.5.ebuild b/dev-libs/libgusb/libgusb-0.2.5.ebuild
new file mode 100644
index 000000000000..8f59bd49161d
--- /dev/null
+++ b/dev-libs/libgusb/libgusb-0.2.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 multilib-minimal vala
+
+DESCRIPTION="GObject wrapper for libusb"
+HOMEPAGE="https://github.com/hughsie/libgusb"
+SRC_URI="http://people.freedesktop.org/~hughsient/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86"
+
+IUSE="+introspection static-libs vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# Yes, we really need API from dev-libs/libusb-1.0.19, not virtual/libusb
+RDEPEND="
+ >=dev-libs/glib-2.28:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libusb-1.0.19[udev,${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.29:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gtk-doc-am
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ vala? ( $(vala_depend) )
+"
+
+# Tests try to access usb devices in /dev
+RESTRICT="test"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_enable vala)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/api/html docs/api/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/dev-libs/libgusb/metadata.xml b/dev-libs/libgusb/metadata.xml
new file mode 100644
index 000000000000..5787e7504aaf
--- /dev/null
+++ b/dev-libs/libgusb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <upstream>
+ <remote-id type="github">hughsie/libgusb</remote-id>
+ </upstream>
+</pkgmetadata>