summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@mobilityhouse.com>2017-12-03 13:49:22 +0100
committerMichael Palimaka <kensington@gentoo.org>2017-12-07 21:29:39 +1100
commit5799c21d2de1f44ef8de29a200692b852cbe67e8 (patch)
tree3a82d0587d3b74bddc9fcf17748cfc9eebb73a4f /dev-libs/libite
parentdev-libs/libuev: Simple event loop for Linux (diff)
downloadgentoo-5799c21d2de1f44ef8de29a200692b852cbe67e8.tar.gz
gentoo-5799c21d2de1f44ef8de29a200692b852cbe67e8.tar.bz2
gentoo-5799c21d2de1f44ef8de29a200692b852cbe67e8.zip
dev-libs/libite: a collection of useful BSD API
Libite is a lightweight library of frog DNA. It can be used to fill the gaps in any dinosaur project. It holds useful functions and macros developed by both Finit and the OpenBSD project. Most notably the string functions: strlcpy(3), strlcat(3) and the highly useful *BSD sys/queue.h and sys/tree.h API's. Closes: https://bugs.gentoo.org/639626 Closes: https://github.com/gentoo/gentoo/pull/6421 Package-Manager: Portage-2.3.13, Repoman-2.3.1
Diffstat (limited to 'dev-libs/libite')
-rw-r--r--dev-libs/libite/Manifest1
-rw-r--r--dev-libs/libite/libite-2.0.0.ebuild23
-rw-r--r--dev-libs/libite/metadata.xml21
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libite/Manifest b/dev-libs/libite/Manifest
new file mode 100644
index 000000000000..cec74c2497bd
--- /dev/null
+++ b/dev-libs/libite/Manifest
@@ -0,0 +1 @@
+DIST libite-2.0.0.tar.xz 259960 BLAKE2B 4c5393daaf2ca6eb830fc5f11b1d38e9c1e2374c5f5d87bb973c7e54b9f81480d4a270a4551689806620cd5a84671d1055d409d6dd090acb64bf7fc454d1c283 SHA512 18516f19d36d81169116562b4b27d76240715424cdde9b87eae831f35adb17d70fb01e2eae5e7e9ce99e2c88344c2c15d2b7d11f4ea2e9ae0deb25ee5ee4c563
diff --git a/dev-libs/libite/libite-2.0.0.ebuild b/dev-libs/libite/libite-2.0.0.ebuild
new file mode 100644
index 000000000000..4dff1da74a46
--- /dev/null
+++ b/dev-libs/libite/libite-2.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A collection of useful BSD APIs"
+HOMEPAGE="https://github.com/troglobit/libite"
+SRC_URI="https://github.com/troglobit/libite/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure(){
+ econf --enable-static=$(usex static-libs)
+}
+
+src_install(){
+ default
+ find "${D}" -name '*.la' -delete || die
+ rm "${D}/usr/share/doc/${PF}/LICENSE" || die
+}
diff --git a/dev-libs/libite/metadata.xml b/dev-libs/libite/metadata.xml
new file mode 100644
index 000000000000..ec1edc5f9935
--- /dev/null
+++ b/dev-libs/libite/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Oz Tiram</name>
+ <email>oz.tiram@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Libite is a lightweight library of frog DNA. It can be used to fill the
+ gaps in any dinosaur project. It holds useful functions and macros
+ developed by both Finit and the OpenBSD project. Most notably the
+ string functions: strlcpy(3), strlcat(3) and the highly useful *BSD
+ sys/queue.h and sys/tree.h API's.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">troglobit/libite</remote-id>
+ </upstream>
+</pkgmetadata>