summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libmacaroons
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libmacaroons')
-rw-r--r--dev-libs/libmacaroons/Manifest2
-rw-r--r--dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild41
-rw-r--r--dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild41
-rw-r--r--dev-libs/libmacaroons/metadata.xml8
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-libs/libmacaroons/Manifest b/dev-libs/libmacaroons/Manifest
new file mode 100644
index 000000000000..404b713b9c98
--- /dev/null
+++ b/dev-libs/libmacaroons/Manifest
@@ -0,0 +1,2 @@
+DIST libmacaroons-0.2.0.tar.gz 423629 SHA256 5fcbfcec06749fccef3f8741ddf4680d032cc55eccdfaa0c9b73429a1df38c33 SHA512 4bc5f83b57c6a8080e646141a3c8b90c0025a894449dea4cb0ab15d1423a067b9833e70014468437d9edfe875e12ea90cae6f715893ded1eefa34f2f6506ecbe WHIRLPOOL 835d15b21c77a97ea1ba717a09356c8b87d27f88dc6bac0da05f21b9977e58affba508c4c123fa6d4139c5090aa1d3dc4e2a88d9fa8b8fa84195c0e44568f841
+DIST libmacaroons-0.3.0.tar.gz 422086 SHA256 8a01587790a8f5d641524b02f4146e2265c437339fea24b34c478240e85afe84 SHA512 57a5ffa1a8397228e29ab3f3f7d1440cd70b163b1b28904a046d7b3b1f70dbb0693ea983409f57cc63a02097a1af57209c70ecf8e3be5b8635a7ab6e498b1bcb WHIRLPOOL c11e44f4b9cf0a996508fc66611a13905c2631d68e6faa883033af229405598d416cc9d0a91efc56e7ab391b33c02d810b1f864a37fec3381fc3929cc2107743
diff --git a/dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild b/dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..4cfbb6bf145a
--- /dev/null
+++ b/dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+# Tests can't function after 2014-12-31 ...
+RESTRICT="test"
+
+DESCRIPTION="Hyperdex macaroons support library"
+
+HOMEPAGE="http://hyperdex.org"
+SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test +python"
+
+RDEPEND="dev-libs/libsodium
+ dev-libs/json-c"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="test? ( python )"
+
+src_prepare() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf $(use_enable python python-bindings)
+}
+
+src_test() {
+ emake -j1 check || die
+}
diff --git a/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild b/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild
new file mode 100644
index 000000000000..4cfbb6bf145a
--- /dev/null
+++ b/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+# Tests can't function after 2014-12-31 ...
+RESTRICT="test"
+
+DESCRIPTION="Hyperdex macaroons support library"
+
+HOMEPAGE="http://hyperdex.org"
+SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test +python"
+
+RDEPEND="dev-libs/libsodium
+ dev-libs/json-c"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="test? ( python )"
+
+src_prepare() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf $(use_enable python python-bindings)
+}
+
+src_test() {
+ emake -j1 check || die
+}
diff --git a/dev-libs/libmacaroons/metadata.xml b/dev-libs/libmacaroons/metadata.xml
new file mode 100644
index 000000000000..24cbb90cf0c4
--- /dev/null
+++ b/dev-libs/libmacaroons/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>