summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libmodbus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libmodbus')
-rw-r--r--dev-libs/libmodbus/Manifest2
-rw-r--r--dev-libs/libmodbus/libmodbus-3.0.6.ebuild26
-rw-r--r--dev-libs/libmodbus/libmodbus-3.1.1.ebuild26
-rw-r--r--dev-libs/libmodbus/metadata.xml9
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/libmodbus/Manifest b/dev-libs/libmodbus/Manifest
new file mode 100644
index 000000000000..6e61f48e60ce
--- /dev/null
+++ b/dev-libs/libmodbus/Manifest
@@ -0,0 +1,2 @@
+DIST libmodbus-3.0.6.tar.gz 504757 SHA256 046d63f10f755e2160dc56ef681e5f5ad3862a57c1955fd82e0ce036b69471b6 SHA512 47a271b3677822701bac924f3e3245e3db72dbadfe1d860ae5d8171b32d2dbb1c761a351d055eafc661a15bc13cb60b793b2b0f9654bbafcf01b457d51991dca WHIRLPOOL f586f4e98083d9eccda7bc49dfda2ff24b167e50fb7cbf9a515066cef179b8a43190daecbf2de0871d09d443ff5d1ec871a77590b8d6f0d992354912a80d5215
+DIST libmodbus-3.1.1.tar.gz 595100 SHA256 76d93aff749d6029f81dcf1fb3fd6abe10c9b48d376f3a03a4f41c5197c95c99 SHA512 0e7b26137b9cdf13decb39a3662767e9309ca4937010a36baba05adb92b7322a85f07557367b80e7242b2cce714007d0e9e6701e127f15f866dae3861e180012 WHIRLPOOL 82ade12450aebad66b0ddd9adf73a1f9f91547e5d7bde85346867ff6a0b991ed532b8b10623e7b79d785092a07b9d34a583114ec573ef7109ec057c714dd4adb
diff --git a/dev-libs/libmodbus/libmodbus-3.0.6.ebuild b/dev-libs/libmodbus/libmodbus-3.0.6.ebuild
new file mode 100644
index 000000000000..f40acebb606c
--- /dev/null
+++ b/dev-libs/libmodbus/libmodbus-3.0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Modbus library which supports RTU communication over a serial line or a TCP link"
+HOMEPAGE="http://libmodbus.org/"
+SRC_URI="http://libmodbus.org/releases/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS MIGRATION NEWS README.rst
+ use static-libs || rm "${D}"/usr/*/libmodbus.la
+}
diff --git a/dev-libs/libmodbus/libmodbus-3.1.1.ebuild b/dev-libs/libmodbus/libmodbus-3.1.1.ebuild
new file mode 100644
index 000000000000..a609319c078e
--- /dev/null
+++ b/dev-libs/libmodbus/libmodbus-3.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Modbus library which supports RTU communication over a serial line or a TCP link"
+HOMEPAGE="http://libmodbus.org/"
+SRC_URI="http://libmodbus.org/releases/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS MIGRATION NEWS README.md
+ use static-libs || rm "${D}"/usr/*/libmodbus.la
+}
diff --git a/dev-libs/libmodbus/metadata.xml b/dev-libs/libmodbus/metadata.xml
new file mode 100644
index 000000000000..59acc2cc580e
--- /dev/null
+++ b/dev-libs/libmodbus/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+