summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/polylib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/polylib')
-rw-r--r--dev-libs/polylib/files/polylib-9999-headers.patch10
-rw-r--r--dev-libs/polylib/metadata.xml5
-rw-r--r--dev-libs/polylib/polylib-9999.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/polylib/files/polylib-9999-headers.patch b/dev-libs/polylib/files/polylib-9999-headers.patch
new file mode 100644
index 000000000000..69b7b271a926
--- /dev/null
+++ b/dev-libs/polylib/files/polylib-9999-headers.patch
@@ -0,0 +1,10 @@
+--- a/applications/ehrhart_union.c
++++ b/applications/ehrhart_union.c
+@@ -1,6 +1,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <unistd.h>
+
+ #include <polylib/polylib.h>
+
diff --git a/dev-libs/polylib/metadata.xml b/dev-libs/polylib/metadata.xml
new file mode 100644
index 000000000000..effbbf33eac8
--- /dev/null
+++ b/dev-libs/polylib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/dev-libs/polylib/polylib-9999.ebuild b/dev-libs/polylib/polylib-9999.ebuild
new file mode 100644
index 000000000000..d1bbe4695696
--- /dev/null
+++ b/dev-libs/polylib/polylib-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EGIT_REPO_URI="git://repo.or.cz/${PN}.git
+ http://repo.or.cz/r/${PN}.git"
+EGIT_BOOTSTRAP="eautoreconf && cd cln && eautoreconf"
+inherit git-2 autotools eutils
+
+DESCRIPTION="ppl port of cloog"
+HOMEPAGE="http://icps.u-strasbg.fr/polylib/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+src_unpack() {
+ git-2_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-headers.patch
+ # strip LDFLAGS from pkgconfig .pc file
+ sed -i '/Libs:/s:@LDFLAGS@::' configure
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc doc/Changes
+}