summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/qrosscore
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/qrosscore')
-rw-r--r--dev-libs/qrosscore/Manifest1
-rw-r--r--dev-libs/qrosscore/metadata.xml11
-rw-r--r--dev-libs/qrosscore/qrosscore-0.3.1.ebuild26
-rw-r--r--dev-libs/qrosscore/qrosscore-9999.ebuild27
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/qrosscore/Manifest b/dev-libs/qrosscore/Manifest
new file mode 100644
index 000000000000..790c13ae132e
--- /dev/null
+++ b/dev-libs/qrosscore/Manifest
@@ -0,0 +1 @@
+DIST qrosscore-0.3.1.tar.gz 3963408 SHA256 0573ece8c78fc836544a87adbb3a61afb1b8821cc11b289935d4b650c2d6bc85 SHA512 0dba2257a18ad36ec5348dc9a298d264f5d3ca1cd08e1bfce50259da85ccf3ebec9bad5e578b99e870948888789e76ce33cc8aaf7538c7da6a732a5c76630be6 WHIRLPOOL ef1c9a6fa7fad7a49c9237ed47bc2e7694d1c89639e62bfcd21c5d253ab40147c8694546db778ed6a16ca06e08a551b5a7a5aacbcc192659291846d87df313d0
diff --git a/dev-libs/qrosscore/metadata.xml b/dev-libs/qrosscore/metadata.xml
new file mode 100644
index 000000000000..ae36ab9f924e
--- /dev/null
+++ b/dev-libs/qrosscore/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>leechcraft</herd>
+ <longdescription lang="en">
+ Qross is a KDE-free version of Kross.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">0xd34df00d/Qross</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/qrosscore/qrosscore-0.3.1.ebuild b/dev-libs/qrosscore/qrosscore-0.3.1.ebuild
new file mode 100644
index 000000000000..678ad21d2b1e
--- /dev/null
+++ b/dev-libs/qrosscore/qrosscore-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="KDE-free version of Kross (core libraries and Qt Script backend)"
+HOMEPAGE="http://github.com/0xd34df00d/Qross"
+SRC_URI="https://github.com/0xd34df00d/Qross/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/designer:4
+ dev-qt/qtscript:4
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/Qross-${PV}/src/qross"
diff --git a/dev-libs/qrosscore/qrosscore-9999.ebuild b/dev-libs/qrosscore/qrosscore-9999.ebuild
new file mode 100644
index 000000000000..10b2465b58cc
--- /dev/null
+++ b/dev-libs/qrosscore/qrosscore-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://github.com/0xd34df00d/Qross.git"
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="KDE-free version of Kross (core libraries and Qt Script backend)"
+HOMEPAGE="http://github.com/0xd34df00d/Qross"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/designer:4
+ dev-qt/qtscript:4
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_USE_DIR="${S}/src/qross"