summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-05-26 12:41:54 +0200
committerDavid Seifert <soap@gentoo.org>2018-05-26 12:42:48 +0200
commit663d2a572c06ac9ce18599aaf393c0466bd9a7d4 (patch)
treec3cbf1f087197a75be594665ef525afd92b85df8 /dev-libs/zookeeper-c
parentapp-text/wv2: Force C++11 (diff)
downloadgentoo-663d2a572c06ac9ce18599aaf393c0466bd9a7d4.tar.gz
gentoo-663d2a572c06ac9ce18599aaf393c0466bd9a7d4.tar.bz2
gentoo-663d2a572c06ac9ce18599aaf393c0466bd9a7d4.zip
dev-libs/zookeeper-c: Force C++11
Closes: https://bugs.gentoo.org/652182 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/zookeeper-c')
-rw-r--r--dev-libs/zookeeper-c/zookeeper-c-3.4.10.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-libs/zookeeper-c/zookeeper-c-3.4.10.ebuild b/dev-libs/zookeeper-c/zookeeper-c-3.4.10.ebuild
index 6530a32be9e4..50be8b701a08 100644
--- a/dev-libs/zookeeper-c/zookeeper-c-3.4.10.ebuild
+++ b/dev-libs/zookeeper-c/zookeeper-c-3.4.10.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+inherit flag-o-matic
+
DESCRIPTION="C client interface to Zookeeper server"
HOMEPAGE="https://zookeeper.apache.org/"
SRC_URI="mirror://apache/zookeeper/zookeeper-${PV}/zookeeper-${PV}.tar.gz"
@@ -20,6 +22,9 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/zookeeper-${PV}/src/c"
src_configure() {
+ # bug 652182
+ append-cxxflags -std=c++11
+
econf \
$(use_enable static-libs static) \
$(use_with test cppunit)
@@ -33,4 +38,8 @@ src_compile() {
src_install() {
default
use doc && dohtml docs/html/*
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
}