summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lua/lanes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lua/lanes')
-rw-r--r--dev-lua/lanes/Manifest1
-rw-r--r--dev-lua/lanes/files/lanes-3.10.0-fix-makefile.patch28
-rw-r--r--dev-lua/lanes/lanes-3.10.0.ebuild32
-rw-r--r--dev-lua/lanes/metadata.xml14
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-lua/lanes/Manifest b/dev-lua/lanes/Manifest
new file mode 100644
index 000000000000..ded9115449c8
--- /dev/null
+++ b/dev-lua/lanes/Manifest
@@ -0,0 +1 @@
+DIST lanes-3.10.0.tar.gz 231359 SHA256 9cb2ac81bf291f0c5a7c7daf67448b2c7fd183b9c36f93c25a8210c11abb2eac SHA512 4a49f560623e291a8344ffef69f4f26fd422d21d3926d73dfee9c9ae9ebd4973e5ae2d307dfd42c5a3bf101bfcc277df54f0a46d89390c83483208e36d4e5d9b WHIRLPOOL e42b9c84e558ee3187b1f18b81abcda7f3b23d8de38cfc060708c7255ae69532fd389556ba8c51c842c6857e135163a0057ea1c122998c4ecedb3831b7d14072
diff --git a/dev-lua/lanes/files/lanes-3.10.0-fix-makefile.patch b/dev-lua/lanes/files/lanes-3.10.0-fix-makefile.patch
new file mode 100644
index 000000000000..52549704248e
--- /dev/null
+++ b/dev-lua/lanes/files/lanes-3.10.0-fix-makefile.patch
@@ -0,0 +1,28 @@
+diff --git a/Makefile b/Makefile
+index fc44fac..6c87e89 100644
+--- a/Makefile
++++ b/Makefile
+@@ -202,17 +202,17 @@ _perftest:
+ #
+ # LUA_LIBDIR and LUA_SHAREDIR are used by the .rockspec (don't change the names!)
+ #
+-DESTDIR=/usr/local
+-LUA_LIBDIR=$(DESTDIR)/lib/lua/5.1
+-LUA_SHAREDIR=$(DESTDIR)/share/lua/5.1
++PREFIX=/usr/local
++LUA_LIBDIR=$(PREFIX)/lib/lua/5.1
++LUA_SHAREDIR=$(PREFIX)/share/lua/5.1
+
+ #
+ # AKa 17-Oct: changed to use 'install -m 644' and 'cp -p'
+ #
+ install: $(_TARGET_SO) src/lanes.lua
+- mkdir -p $(LUA_LIBDIR) $(LUA_LIBDIR)/lanes $(LUA_SHAREDIR)
+- install -m 644 $(_TARGET_SO) $(LUA_LIBDIR)/lanes
+- cp -p src/lanes.lua $(LUA_SHAREDIR)
++ mkdir -p $(DESTDIR)$(LUA_LIBDIR)/lanes $(DESTDIR)$(LUA_SHAREDIR)
++ install -m 644 $(_TARGET_SO) $(DESTDIR)$(LUA_LIBDIR)/lanes
++ cp -p src/lanes.lua $(DESTDIR)$(LUA_SHAREDIR)
+
+
+ #--- Packaging ---
diff --git a/dev-lua/lanes/lanes-3.10.0.ebuild b/dev-lua/lanes/lanes-3.10.0.ebuild
new file mode 100644
index 000000000000..97d453281f60
--- /dev/null
+++ b/dev-lua/lanes/lanes-3.10.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="lightweight, native, lazy evaluating multithreading library"
+HOMEPAGE="https://github.com/LuaLanes/lanes"
+SRC_URI="http://github.com/LuaLanes/lanes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ tc-export CC
+ epatch "${FILESDIR}"/${P}-fix-makefile.patch
+ sed -i -e "s#/lib#/$(get_libdir)#" Makefile || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc ABOUT BUGS CHANGES README TODO
+dohtml -r docs/*
+}
diff --git a/dev-lua/lanes/metadata.xml b/dev-lua/lanes/metadata.xml
new file mode 100644
index 000000000000..9a127d533710
--- /dev/null
+++ b/dev-lua/lanes/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <longdescription lang="en">
+ lightweight, native, lazy evaluating multithreading library for Lua-5.1 or 5.2.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">LuaLanes/lanes</remote-id>
+ </upstream>
+</pkgmetadata>