summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/pxp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/pxp')
-rw-r--r--dev-ml/pxp/Manifest2
-rw-r--r--dev-ml/pxp/metadata.xml5
-rw-r--r--dev-ml/pxp/pxp-1.2.4.ebuild51
-rw-r--r--dev-ml/pxp/pxp-1.2.7.ebuild51
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-ml/pxp/Manifest b/dev-ml/pxp/Manifest
new file mode 100644
index 000000000000..eff83f850bbd
--- /dev/null
+++ b/dev-ml/pxp/Manifest
@@ -0,0 +1,2 @@
+DIST pxp-1.2.4.tar.gz 702365 SHA256 1cd3e946f19d800f412475adf56e6da87231f80be22d7ea71dd4eabf93876355 SHA512 1520dd732db17923c24d43c328e659db83ac00569e7d2153e5633dfbc3fad899db8e45523ea76915e5dd1cb71cda2500db3875deebdf47b375af5bd05ad383d6 WHIRLPOOL 26c54816a63b26cee4cbaa7c3c868f449c40291eff1a242ade45f5c08f89afd7ef8b12ff3da5b00608f8ede486d17b1fd1387f0042c42e79d08e76f43c97089f
+DIST pxp-1.2.7.tar.gz 735710 SHA256 2b0aca564f71c87825436e31a82de2ca3b3e99ee81a83840a525b0be63d73025 SHA512 11b49edc8e93a867b39d99ed6117460b3ecc7f9368564c815125662897f3cfbd87876b68c794bfd73b28cb0d8a898500ccd8ce0e1fca205bbce8b9759fa684d3 WHIRLPOOL 728f708c5dc332179884a4c2b6a222c514e8153c3bdf67847361df323886d61e320672f7dc7bd695343a641b34c9742c94f3cd9065541622670cb8b3df22380d
diff --git a/dev-ml/pxp/metadata.xml b/dev-ml/pxp/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/pxp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/pxp/pxp-1.2.4.ebuild b/dev-ml/pxp/pxp-1.2.4.ebuild
new file mode 100644
index 000000000000..e1ce8a240095
--- /dev/null
+++ b/dev-ml/pxp/pxp-1.2.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib eutils
+
+MY_P=${P/_beta/test}
+
+DESCRIPTION="validating XML parser library for O'Caml"
+HOMEPAGE="http://projects.camlcity.org/projects/pxp.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="amd64 ~ppc x86"
+
+SLOT="0/${PV}"
+DEPEND=">=dev-ml/pcre-ocaml-4.31:=
+ >=dev-ml/ulex-0.5:=
+ >=dev-ml/ocamlnet-0.98:=
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+
+IUSE="examples +ocamlopt"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ #the included configure does not support many standard switches and is quite picky
+ ./configure || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ cd doc
+ dodoc ABOUT-FINDLIB README SPEC design.txt
+}
diff --git a/dev-ml/pxp/pxp-1.2.7.ebuild b/dev-ml/pxp/pxp-1.2.7.ebuild
new file mode 100644
index 000000000000..1937ee73d8e9
--- /dev/null
+++ b/dev-ml/pxp/pxp-1.2.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib eutils
+
+MY_P=${P/_beta/test}
+
+DESCRIPTION="validating XML parser library for O'Caml"
+HOMEPAGE="http://projects.camlcity.org/projects/pxp.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SLOT="0/${PV}"
+DEPEND=">=dev-ml/pcre-ocaml-4.31:=
+ >=dev-ml/ulex-0.5:=
+ >=dev-ml/ocamlnet-0.98:=
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+
+IUSE="examples +ocamlopt"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ #the included configure does not support many standard switches and is quite picky
+ ./configure || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ cd doc
+ dodoc ABOUT-FINDLIB README SPEC design.txt
+}