summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Acme-Damn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Acme-Damn')
-rw-r--r--dev-perl/Acme-Damn/Acme-Damn-0.50.0.ebuild22
-rw-r--r--dev-perl/Acme-Damn/Acme-Damn-0.60.0.ebuild28
-rw-r--r--dev-perl/Acme-Damn/Manifest2
-rw-r--r--dev-perl/Acme-Damn/files/Acme-Damn-respect-cflags.patch10
-rw-r--r--dev-perl/Acme-Damn/metadata.xml13
5 files changed, 75 insertions, 0 deletions
diff --git a/dev-perl/Acme-Damn/Acme-Damn-0.50.0.ebuild b/dev-perl/Acme-Damn/Acme-Damn-0.50.0.ebuild
new file mode 100644
index 000000000000..9a804fdd3c9c
--- /dev/null
+++ b/dev-perl/Acme-Damn/Acme-Damn-0.50.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=IBB
+MODULE_VERSION=0.05
+inherit perl-module
+
+DESCRIPTION="Module, that 'unblesses' Perl objects"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-perl/Test-Exception )"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${PN}-respect-cflags.patch" )
+
+SRC_TEST="do"
diff --git a/dev-perl/Acme-Damn/Acme-Damn-0.60.0.ebuild b/dev-perl/Acme-Damn/Acme-Damn-0.60.0.ebuild
new file mode 100644
index 000000000000..f9de1cf87153
--- /dev/null
+++ b/dev-perl/Acme-Damn/Acme-Damn-0.60.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=IBB
+MODULE_VERSION=0.06
+inherit perl-module
+
+DESCRIPTION="Module, that 'unblesses' Perl objects"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-respect-cflags.patch" )
+
+SRC_TEST="do"
diff --git a/dev-perl/Acme-Damn/Manifest b/dev-perl/Acme-Damn/Manifest
new file mode 100644
index 000000000000..f159f6de7d28
--- /dev/null
+++ b/dev-perl/Acme-Damn/Manifest
@@ -0,0 +1,2 @@
+DIST Acme-Damn-0.05.tar.gz 8363 SHA256 a8e8c122ffdf7f34a0a20472efd59514944766e4d9bbb58d1440bc44b6d2bfd8 SHA512 19b46816adbd7087cbffb6bca8437051a888f9e81fca8b033eac4c906a67e4695690adf7cf8333c066cbb3d7045b6ae086daf0e64f0dcd06c5b0226fe02b4409 WHIRLPOOL a10480e963163884f258a42500f42e53cd013b31f5061559f014059e5abb8cf106dec0f3c2b6bac75e6130b811e9636758660ad3de5e74ce9dcd06773be97be7
+DIST Acme-Damn-0.06.tar.gz 8635 SHA256 7925c932b9f89d2ca413680af68ed9809e7093e4ecd5bc2bd4147bdaee39ee6f SHA512 f225e5f835ce9b054087008d354278356704694147cf8e1027c0bd2c4a8c118ebbdeac2c97634e4c85cf45d29bf38a92861770c35b8423b6f12a1bc6319ff52d WHIRLPOOL 50b288b6a313505238935b0f58d4885407ad6f0c349696c229ad874e6b67f92f7d00eb3a8ace474e47d1f66c321c881d50009b07478d9994e5ba8795d2a02470
diff --git a/dev-perl/Acme-Damn/files/Acme-Damn-respect-cflags.patch b/dev-perl/Acme-Damn/files/Acme-Damn-respect-cflags.patch
new file mode 100644
index 000000000000..1324e8bd63f2
--- /dev/null
+++ b/dev-perl/Acme-Damn/files/Acme-Damn-respect-cflags.patch
@@ -0,0 +1,10 @@
+--- Makefile.PL.orig 2013-07-13 15:39:13.091479998 +0400
++++ Makefile.PL 2013-07-13 15:39:45.418479431 +0400
+@@ -18,5 +18,6 @@
+ ( AUTHOR => 'Ian Brayshaw <ian@onemore.org>') : ()) ,
+ 'LIBS' => [''] ,
+ 'DEFINE' => '' ,
+- 'INC' => '-I.'
++ 'INC' => '-I.' ,
++ 'OPTIMIZE' => '$(CFLAGS)'
+ );
diff --git a/dev-perl/Acme-Damn/metadata.xml b/dev-perl/Acme-Damn/metadata.xml
new file mode 100644
index 000000000000..4df81c71fcd4
--- /dev/null
+++ b/dev-perl/Acme-Damn/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Acme-Damn</remote-id>
+ <remote-id type="cpan-module">Acme::Damn</remote-id>
+ </upstream>
+</pkgmetadata>