summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Apache-Test
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Apache-Test')
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.380.0-r1.ebuild35
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.390.0.ebuild37
-rw-r--r--dev-perl/Apache-Test/Manifest2
-rw-r--r--dev-perl/Apache-Test/metadata.xml47
4 files changed, 121 insertions, 0 deletions
diff --git a/dev-perl/Apache-Test/Apache-Test-1.380.0-r1.ebuild b/dev-perl/Apache-Test/Apache-Test-1.380.0-r1.ebuild
new file mode 100644
index 000000000000..20e3f09df763
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.380.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.38
+inherit depend.apache perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+# interactive, requires interaction with the live filesystem
+SRC_TEST="skip"
+
+need_apache
+
+pkg_setup() {
+ perl_set_version
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [ -f "${S}"/.mypacklist ];
+ then
+ rm -f "${S}"/.mypacklist
+ fi
+ perl-module_src_install
+}
diff --git a/dev-perl/Apache-Test/Apache-Test-1.390.0.ebuild b/dev-perl/Apache-Test/Apache-Test-1.390.0.ebuild
new file mode 100644
index 000000000000..aa34d78c3d2e
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.390.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SHAY
+MODULE_VERSION=1.39
+inherit depend.apache perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+# interactive, requires interaction with the live filesystem
+SRC_TEST="skip"
+
+need_apache
+
+pkg_setup() {
+ perl_set_version
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [ -f "${S}"/.mypacklist ];
+ then
+ rm -f "${S}"/.mypacklist
+ fi
+ perl-module_src_install
+}
diff --git a/dev-perl/Apache-Test/Manifest b/dev-perl/Apache-Test/Manifest
new file mode 100644
index 000000000000..f74fe51fab8b
--- /dev/null
+++ b/dev-perl/Apache-Test/Manifest
@@ -0,0 +1,2 @@
+DIST Apache-Test-1.38.tar.gz 150863 SHA256 321717f58636ed0aa85cba6d69fc01e2ccbc90ba71ec2dcc2134d8401af65145 SHA512 416a89990e1947dfd970b806a28b52197165bbe1a482402aa5649f6e2692866a54cc8a4a7adcce83350e2f16aada409fd6c506c0d139b624319c5ebaa58604cc WHIRLPOOL 6f5724b9e56dcd268c8dfa3469b85e6f3f9ef02e9e524386d0af12377d9e560831155913392f04ef9e7b130b0b495e1e5e013a52cd0f4c747507f8f845665e6c
+DIST Apache-Test-1.39.tar.gz 151240 SHA256 d8543864ff29e8ac3d4004c5c7014b1fe490b2024104ac4c24683a74bba62089 SHA512 4f10b0ed856d03aff27aa80d9788f0a2f50eac3523cc7ecf74fec2cda4c881fda2ec096ca238539eb8c4aa2caa4daaa192456f34d00ad8012276c1d87fcc3533 WHIRLPOOL 01a77e14a1464a0caa8154dd4ff68b6b6dc5e7220ae1d4efe63e2a9eb2134ec94d0d5b73c6701de21c0a7d620d1e4bfe2db768c2cd08d9a984609bb7186beaea
diff --git a/dev-perl/Apache-Test/metadata.xml b/dev-perl/Apache-Test/metadata.xml
new file mode 100644
index 000000000000..045d71022b15
--- /dev/null
+++ b/dev-perl/Apache-Test/metadata.xml
@@ -0,0 +1,47 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <longdescription>The Apache::Test framework was designed for creating test
+ suites for products running on the Apache httpd webserver (not
+ necessarily mod_perl). Originally designed for the mod_perl Apache
+ module, it was extended to be used for any Apache
+ module.</longdescription>
+ <upstream>
+ <remote-id type="cpan">Apache-Test</remote-id>
+ <remote-id type="cpan-module">Apache::Test</remote-id>
+ <remote-id type="cpan-module">Apache::Test5005compat</remote-id>
+ <remote-id type="cpan-module">Apache::TestBuild</remote-id>
+ <remote-id type="cpan-module">Apache::TestClient</remote-id>
+ <remote-id type="cpan-module">Apache::TestClientResponse</remote-id>
+ <remote-id type="cpan-module">Apache::TestCommon</remote-id>
+ <remote-id type="cpan-module">Apache::TestCommonPost</remote-id>
+ <remote-id type="cpan-module">Apache::TestConfig</remote-id>
+ <remote-id type="cpan-module">Apache::TestConfigC</remote-id>
+ <remote-id type="cpan-module">Apache::TestConfigPHP</remote-id>
+ <remote-id type="cpan-module">Apache::TestConfigParrot</remote-id>
+ <remote-id type="cpan-module">Apache::TestHandler</remote-id>
+ <remote-id type="cpan-module">Apache::TestHarness</remote-id>
+ <remote-id type="cpan-module">Apache::TestHarnessPHP</remote-id>
+ <remote-id type="cpan-module">Apache::TestMB</remote-id>
+ <remote-id type="cpan-module">Apache::TestMM</remote-id>
+ <remote-id type="cpan-module">Apache::TestReport</remote-id>
+ <remote-id type="cpan-module">Apache::TestReportPerl</remote-id>
+ <remote-id type="cpan-module">Apache::TestRequest</remote-id>
+ <remote-id type="cpan-module">Apache::TestRun</remote-id>
+ <remote-id type="cpan-module">Apache::TestRunPHP</remote-id>
+ <remote-id type="cpan-module">Apache::TestRunParrot</remote-id>
+ <remote-id type="cpan-module">Apache::TestRunPerl</remote-id>
+ <remote-id type="cpan-module">Apache::TestSSLCA</remote-id>
+ <remote-id type="cpan-module">Apache::TestServer</remote-id>
+ <remote-id type="cpan-module">Apache::TestSmoke</remote-id>
+ <remote-id type="cpan-module">Apache::TestSmokePerl</remote-id>
+ <remote-id type="cpan-module">Apache::TestSort</remote-id>
+ <remote-id type="cpan-module">Apache::TestToString</remote-id>
+ <remote-id type="cpan-module">Apache::TestTrace</remote-id>
+ <remote-id type="cpan-module">Apache::TestUtil</remote-id>
+ <remote-id type="cpan-module">Bundle::ApacheTest</remote-id>
+ <remote-id type="cpan-module">HTTP::Request::Common</remote-id>
+ <remote-id type="cpan-module">warnings</remote-id>
+ </upstream>
+</pkgmetadata>