summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/B-Hooks-Parser
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/B-Hooks-Parser')
-rw-r--r--dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.120.0-r1.ebuild22
-rw-r--r--dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.130.0.ebuild22
-rw-r--r--dev-perl/B-Hooks-Parser/Manifest2
-rw-r--r--dev-perl/B-Hooks-Parser/metadata.xml9
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.120.0-r1.ebuild b/dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.120.0-r1.ebuild
new file mode 100644
index 000000000000..6c26266ca96f
--- /dev/null
+++ b/dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.120.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=0.12
+inherit perl-module
+
+DESCRIPTION="Interface to perls parser variables"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/B-Hooks-OP-Check"
+DEPEND="${RDEPEND}
+ >=dev-perl/ExtUtils-Depends-0.302
+ test? ( dev-perl/Test-Exception
+ dev-perl/B-Hooks-EndOfScope )"
+SRC_TEST=do
diff --git a/dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.130.0.ebuild b/dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.130.0.ebuild
new file mode 100644
index 000000000000..6fe32a7aa80c
--- /dev/null
+++ b/dev-perl/B-Hooks-Parser/B-Hooks-Parser-0.130.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=0.13
+inherit perl-module
+
+DESCRIPTION="Interface to perls parser variables"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/B-Hooks-OP-Check"
+DEPEND="${RDEPEND}
+ >=dev-perl/ExtUtils-Depends-0.302
+ test? ( dev-perl/Test-Exception
+ dev-perl/B-Hooks-EndOfScope )"
+SRC_TEST=do
diff --git a/dev-perl/B-Hooks-Parser/Manifest b/dev-perl/B-Hooks-Parser/Manifest
new file mode 100644
index 000000000000..598f91f04265
--- /dev/null
+++ b/dev-perl/B-Hooks-Parser/Manifest
@@ -0,0 +1,2 @@
+DIST B-Hooks-Parser-0.12.tar.gz 72662 SHA256 cddbc1e664975ef1e35b5f9361ff993d9005507201463f9e5561a056ffbadb25 SHA512 d6c6cbe521362ec9b5efd7d4b920f26bd35a8d37073d2f803d9e0a6d1965b712ea4ba5d2cc8f4d8195fd3f71c7a247202055295395df733c997eb0c3d290a7e5 WHIRLPOOL 9c38e6b29193de7f1748130e3e25d24168beab0b43da3bdfe64355925fd11c21ece983f313d594a60c7e634b00da6ce68b163116662a88aa952cb66b7c71c415
+DIST B-Hooks-Parser-0.13.tar.gz 83951 SHA256 f6c838e59f52e21ccc0b2c9d85d6f7ba33119098ad3a261698b01690c2619646 SHA512 f1729830350d25f5decc4b08be23591920683d86d910bec99b478e58905dee6cc384af305b665a8a90dc48b9b819df6cbc975cf606b495448d25d00e3357a149 WHIRLPOOL d6505cbb95834b0a6084af24ba4f1ba96704016cf0180a79e479036d98567c29fbc42f60b91e5c72068e5403dc581d56c5b0493e173965ee571f9ce442094725
diff --git a/dev-perl/B-Hooks-Parser/metadata.xml b/dev-perl/B-Hooks-Parser/metadata.xml
new file mode 100644
index 000000000000..ae2fbc836359
--- /dev/null
+++ b/dev-perl/B-Hooks-Parser/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">B-Hooks-Parser</remote-id>
+ <remote-id type="cpan-module">B::Hooks::Parser</remote-id>
+ </upstream>
+</pkgmetadata>