summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/B-Utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/B-Utils')
-rw-r--r--dev-perl/B-Utils/B-Utils-0.260.0.ebuild30
-rw-r--r--dev-perl/B-Utils/B-Utils-0.270.0.ebuild31
-rw-r--r--dev-perl/B-Utils/Manifest2
-rw-r--r--dev-perl/B-Utils/metadata.xml11
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-perl/B-Utils/B-Utils-0.260.0.ebuild b/dev-perl/B-Utils/B-Utils-0.260.0.ebuild
new file mode 100644
index 000000000000..a0a4ce077752
--- /dev/null
+++ b/dev-perl/B-Utils/B-Utils-0.260.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=0.26
+inherit perl-module
+
+DESCRIPTION="Helper functions for op tree manipulation"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Exporter
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Task-Weaken
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/ExtUtils-Depends-0.301.0
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/B-Utils/B-Utils-0.270.0.ebuild b/dev-perl/B-Utils/B-Utils-0.270.0.ebuild
new file mode 100644
index 000000000000..f1adb897520d
--- /dev/null
+++ b/dev-perl/B-Utils/B-Utils-0.270.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=0.27
+inherit perl-module
+
+DESCRIPTION="Helper functions for op tree manipulation"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+# needs Scalar::Util
+RDEPEND="
+ virtual/perl-Exporter
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Task-Weaken
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/ExtUtils-Depends-0.301.0
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/B-Utils/Manifest b/dev-perl/B-Utils/Manifest
new file mode 100644
index 000000000000..51d8443c6c22
--- /dev/null
+++ b/dev-perl/B-Utils/Manifest
@@ -0,0 +1,2 @@
+DIST B-Utils-0.26.tar.gz 73325 SHA256 15f9143bb86893813f5acdbe01deb84bafd45e725b536e15984fefc9f64c97e0 SHA512 14fb9f3b1ba95181c5e57368350fec60e5933e813278d522fec122f0888fe4bd84ca75a798722cefee07e3f7cb2ffec1cd0535d956bc7f0ef26504f9a65200d9 WHIRLPOOL a217fa2491fb2de6a485f527f8cc012ff5d666b4ec402ca87e66ea651db812059b0f682d37afea82b69ae67b9ad43fb629122eecfa462b903b5fbc1499f6086b
+DIST B-Utils-0.27.tar.gz 74612 SHA256 f97f53f6a3050109aa414feeb184cad101812d41760e952b5d84993f6685ffea SHA512 a896476f59a424fa9062c5dfe6431493c020e51746fa7f7b4c7fcdb109d1c0fa252292b891263d676884f064db95f16958a5d2ed5981dc5997436dced6579e74 WHIRLPOOL 86ebdf04f8e659f21a2e546412313e8287e41ba9b93beb2e2658d20736b92bd72c82804c16464a6f3f5e987404ca8560fcd2521b3a926c9386f3cdc8f410aee6
diff --git a/dev-perl/B-Utils/metadata.xml b/dev-perl/B-Utils/metadata.xml
new file mode 100644
index 000000000000..062301e6192d
--- /dev/null
+++ b/dev-perl/B-Utils/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">B-Utils</remote-id>
+ <remote-id type="cpan-module">B::Utils</remote-id>
+ <remote-id type="cpan-module">B::Utils::Install::Files</remote-id>
+ <remote-id type="cpan-module">B::Utils::OP</remote-id>
+ </upstream>
+</pkgmetadata>