summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Class-Std
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Class-Std')
-rw-r--r--dev-perl/Class-Std/Class-Std-0.11.0-r1.ebuild41
-rw-r--r--dev-perl/Class-Std/Manifest2
-rw-r--r--dev-perl/Class-Std/metadata.xml10
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-perl/Class-Std/Class-Std-0.11.0-r1.ebuild b/dev-perl/Class-Std/Class-Std-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..6f51554530c1
--- /dev/null
+++ b/dev-perl/Class-Std/Class-Std-0.11.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR="DCONWAY"
+MODULE_VERSION=0.011
+inherit perl-module
+
+DESCRIPTION='Support for creating standard "inside-out" classes'
+SRC_URI+=" http://dev.gentoo.org/~tove/distfiles/${CATEGORY}/${PN}/${P}-patch.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Data-Dumper
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do"
+
+EPATCH_SUFFIX=patch
+PATCHES=(
+ "${WORKDIR}"/${MY_PN:-${PN}}-patch
+)
+
+PERL_RM_FILES=(
+ t/pod.t
+ t/pod-coverage.t
+)
diff --git a/dev-perl/Class-Std/Manifest b/dev-perl/Class-Std/Manifest
new file mode 100644
index 000000000000..d4f3d60de853
--- /dev/null
+++ b/dev-perl/Class-Std/Manifest
@@ -0,0 +1,2 @@
+DIST Class-Std-0.011.tar.gz 31080 SHA256 454ac2f99fb45735709c0bf1d04f8e0c162abd26026fbc1895cb71de191ecfa2 SHA512 b2387a2873257dcd5cec71850193fe8eee655bc669a951bd87b011cc8ef5637caad8cdc34f2e1daf85f3231905545e68b112380f006a75f9f97f58ef3f8860ec WHIRLPOOL 058f23be1661d06def4ad08ae02fc0d21ea561efb75c683ad1caefa424d2a05c8bf47d9e1a70a661c290509ee11ff14f893b3fc225163db4aafbde552ce77d98
+DIST Class-Std-0.11.0-patch.tar.bz2 379 SHA256 54f42413f0204b6e262d31caa5ca2384842cf9e86221e2cb1beaea9f88f65251 SHA512 b253f76b1fec87bbd184896fe92da57e87da7b43dc55c1425c6e3ae7072ede1641c8cac3e81c51bef97bd8dfa7fdf85019d0592efd933528ff0970c7b36b1633 WHIRLPOOL bd8374c00db79f3a2340f35c0c9c517ff00296c57d6c20dde485d014c1a74e79b5b38ebacbcc65b668318c5702c61bfb27fa8b770949295e0becb3b2888e63b5
diff --git a/dev-perl/Class-Std/metadata.xml b/dev-perl/Class-Std/metadata.xml
new file mode 100644
index 000000000000..cbe20b9a6c63
--- /dev/null
+++ b/dev-perl/Class-Std/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Class-Std</remote-id>
+ <remote-id type="cpan-module">Class::Std</remote-id>
+ <remote-id type="cpan-module">Class::Std::SCR</remote-id>
+ </upstream>
+</pkgmetadata>