summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Config-Tiny
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Config-Tiny')
-rw-r--r--dev-perl/Config-Tiny/Config-Tiny-2.160.0.ebuild26
-rw-r--r--dev-perl/Config-Tiny/Config-Tiny-2.220.0.ebuild29
-rw-r--r--dev-perl/Config-Tiny/Manifest2
-rw-r--r--dev-perl/Config-Tiny/metadata.xml9
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-perl/Config-Tiny/Config-Tiny-2.160.0.ebuild b/dev-perl/Config-Tiny/Config-Tiny-2.160.0.ebuild
new file mode 100644
index 000000000000..c4a917d20227
--- /dev/null
+++ b/dev-perl/Config-Tiny/Config-Tiny-2.160.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RSAVAGE
+MODULE_VERSION=2.16
+MODULE_A_EXT="tgz"
+inherit perl-module
+
+DESCRIPTION="Read/Write .ini style files with as little code as possible"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="test"
+
+DEPEND=">=dev-perl/Module-Build-0.380.0
+ test? (
+ >=virtual/perl-File-Spec-3.300.0
+ >=virtual/perl-File-Temp-0.220.0
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Config-Tiny/Config-Tiny-2.220.0.ebuild b/dev-perl/Config-Tiny/Config-Tiny-2.220.0.ebuild
new file mode 100644
index 000000000000..f4aff2f5b5bd
--- /dev/null
+++ b/dev-perl/Config-Tiny/Config-Tiny-2.220.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RSAVAGE
+MODULE_VERSION=2.22
+MODULE_A_EXT="tgz"
+inherit perl-module
+
+DESCRIPTION="Read/Write .ini style files with as little code as possible"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-File-Spec-3.300.0
+ >=virtual/perl-File-Temp-0.220.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Config-Tiny/Manifest b/dev-perl/Config-Tiny/Manifest
new file mode 100644
index 000000000000..2503ec4666f4
--- /dev/null
+++ b/dev-perl/Config-Tiny/Manifest
@@ -0,0 +1,2 @@
+DIST Config-Tiny-2.16.tgz 23972 SHA256 22ba95108d362b1029c324f2fd152c1958bee66a2fae7ea4309c0c63c862ae4b SHA512 8faea2b1ecc54adf05778b76fdbd8c5df7a86b32da9ecee43f9a7c6659d72b4902940e003430e7b86cffffff8e93f3b39d08bad263c41e4329a9a39aea0ebb00 WHIRLPOOL 1492f67572ed4bb583c9336339526fe67e6efd3496069c2419af954887ef6ba3d442d2a2681e211729ecab16dc6fa2511f5abba86ac1eb387b07267c91f29004
+DIST Config-Tiny-2.22.tgz 20134 SHA256 91ce9728743db3d1b5b8be87e68d18de07b2eda15d8dd53423543e4e9c5b1324 SHA512 cc3c73775b0c44c05f0be2fb327438156bb0175139fb6bd414d197d45ce881776dd3776d05e06679f4ed133ff299720b4acc239fe3630f051ca38d331f2d4d64 WHIRLPOOL 77e5d979e2ff6ab4c240594f2479ce403b8ea8a4b344350b066af1eaa9108c0443bc33993034005ac58de9c51ac79ad0d8890893b3fc48f4c0f3e38c1124336e
diff --git a/dev-perl/Config-Tiny/metadata.xml b/dev-perl/Config-Tiny/metadata.xml
new file mode 100644
index 000000000000..004a791cf70f
--- /dev/null
+++ b/dev-perl/Config-Tiny/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Config-Tiny</remote-id>
+ <remote-id type="cpan-module">Config::Tiny</remote-id>
+ </upstream>
+</pkgmetadata>