summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/DBD-Pg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/DBD-Pg')
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-2.19.3-r1.ebuild42
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.3.0.ebuild42
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.4.2.ebuild42
-rw-r--r--dev-perl/DBD-Pg/Manifest3
-rw-r--r--dev-perl/DBD-Pg/metadata.xml10
5 files changed, 139 insertions, 0 deletions
diff --git a/dev-perl/DBD-Pg/DBD-Pg-2.19.3-r1.ebuild b/dev-perl/DBD-Pg/DBD-Pg-2.19.3-r1.ebuild
new file mode 100644
index 000000000000..9da39816cb32
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-2.19.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=TURNSTEP
+MODULE_VERSION=2.19.3
+inherit perl-module
+
+DESCRIPTION="The Perl DBD::Pg Module"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/perl-version
+ >=dev-perl/DBI-1.52
+ dev-db/postgresql"
+DEPEND="${RDEPEND}"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.3.0.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.3.0.ebuild
new file mode 100644
index 000000000000..9dd3c901247d
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-3.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=TURNSTEP
+MODULE_VERSION=3.3.0
+inherit perl-module
+
+DESCRIPTION="The Perl DBD::Pg Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/perl-version
+ >=dev-perl/DBI-1.52
+ dev-db/postgresql"
+DEPEND="${RDEPEND}"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.4.2.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.4.2.ebuild
new file mode 100644
index 000000000000..7f74837758e1
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-3.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=TURNSTEP
+MODULE_VERSION=3.4.2
+inherit perl-module
+
+DESCRIPTION="PostgreSQL database driver for the DBI module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/perl-version
+ >=dev-perl/DBI-1.614.0
+ dev-db/postgresql"
+DEPEND="${RDEPEND}"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}
diff --git a/dev-perl/DBD-Pg/Manifest b/dev-perl/DBD-Pg/Manifest
new file mode 100644
index 000000000000..2ad0cb1cd213
--- /dev/null
+++ b/dev-perl/DBD-Pg/Manifest
@@ -0,0 +1,3 @@
+DIST DBD-Pg-2.19.3.tar.gz 237399 SHA256 37350d134b7fa88fb3b9432d92991e0a73f405bf5b3a4ee53430439280b8262a SHA512 e1183fda7abcd2ee05491fe269172e5fb09dba6cb329c6f6f1a5abb9dc9a98c414a0b67f3465b938b197bbe34e3ebc9ec6a4e810e1f9e2316753845ac5416fec WHIRLPOOL 427b1705a3d8e69032b2db5d7ad1d1c6de6353c44b5b6294352abfb28f100f2f572356a2402e285bfbb373384bff18fef7355c545ceb21fbffea07d5de75ec24
+DIST DBD-Pg-3.3.0.tar.gz 251408 SHA256 52f43de5b2d916d447d7ed252b127f728b226dc88db57d4fe9712e21d3586ffe SHA512 eb8fbc2e9ad3a846ee4ee580ad2d18cb99b8df48b1c30595d0ffc6ab6e0ff91c36f61e98120968285bd3818f0e565a43189066eda8f93a2972e1df3258ed4f8e WHIRLPOOL b0143c95422ca7e8566b7bf7b63ff8d83e5304a0a83b93a5acff30a3d2140243fb580fa36ac70aeebf8226d7990d56fd85b0ae942310944c21564b7b933b662a
+DIST DBD-Pg-3.4.2.tar.gz 253346 SHA256 7b76930cec143b90a068e1e64a3beb6f640c10b22d0a41f9a032516683892f24 SHA512 290f8e19d6920c1a514305a943ec4f63da14dd321e93a6e9cc4f6fce6737f308a3931135ec9ed0d4577f1ab97358106ca2def7ccb28a7c5c169a80ca5cda1d85 WHIRLPOOL a177efa5cd07c3064528329a9be72cd464671e55ac19ec564b75f8fe5e757c960a89d83d09a65e7e327bb88d9322465c0cdc320ddb33eb85a59bb29c9fe1dfbe
diff --git a/dev-perl/DBD-Pg/metadata.xml b/dev-perl/DBD-Pg/metadata.xml
new file mode 100644
index 000000000000..dfb7e1a2dc36
--- /dev/null
+++ b/dev-perl/DBD-Pg/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">DBD-Pg</remote-id>
+ <remote-id type="cpan-module">Bundle::DBD::Pg</remote-id>
+ <remote-id type="cpan-module">DBD::Pg</remote-id>
+ </upstream>
+</pkgmetadata>